summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-20 21:34:11 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-20 21:34:11 +0000
commit6f794883e8beea817629ce1ea9a155a1504664bb (patch)
treefd3358667ba73d91744143a48d81680283865233 /dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild
parentbumped EAPI to 5; committed directly to stable as no other changes present an... (diff)
downloadgentoo-2-6f794883e8beea817629ce1ea9a155a1504664bb.tar.gz
gentoo-2-6f794883e8beea817629ce1ea9a155a1504664bb.tar.bz2
gentoo-2-6f794883e8beea817629ce1ea9a155a1504664bb.zip
bumped EAPI to 5; committed 1.350.0 bump directly to stable as no other changes present and revbump helps stable systems to keep from dieing on perl-5.18 upgrade
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild')
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild
new file mode 100644
index 000000000000..b925e7da8180
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0-r1.ebuild,v 1.1 2014/08/20 21:34:11 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-db/sqlite-3.6.22[extensions(+)]
+ >=dev-perl/DBI-1.57
+ !<dev-perl/DBD-SQLite-1
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.86
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+}