summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-03 21:54:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-03 21:54:29 +0000
commitfeffebcf1b06160d20dc17350fe3cf1eb24164f4 (patch)
tree441087241b89f643b12081eac27141614296148c /dev-ml
parentVersion bump. (diff)
downloadgentoo-2-feffebcf1b06160d20dc17350fe3cf1eb24164f4.tar.gz
gentoo-2-feffebcf1b06160d20dc17350fe3cf1eb24164f4.tar.bz2
gentoo-2-feffebcf1b06160d20dc17350fe3cf1eb24164f4.zip
version bump, add optional support for ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/extlib/ChangeLog9
-rw-r--r--dev-ml/extlib/extlib-1.5.1.ebuild47
-rw-r--r--dev-ml/extlib/files/digest-extlib-1.5.13
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index e04ab81b38bb..1cec65765cf9 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/extlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.4 2007/02/21 00:49:35 nattfodd Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.5 2008/01/03 21:54:28 aballier Exp $
+
+*extlib-1.5.1 (03 Jan 2008)
+
+ 03 Jan 2008; Alexis Ballier <aballier@gentoo.org> +extlib-1.5.1.ebuild:
+ version bump, add optional support for ocamlopt
21 Feb 2007; Alexandre Buisse <nattfodd@gentoo.org> extlib-1.5.ebuild:
Removed multiple inherit (thanks to Jokey for reporting).
diff --git a/dev-ml/extlib/extlib-1.5.1.ebuild b/dev-ml/extlib/extlib-1.5.1.ebuild
new file mode 100644
index 000000000000..03bcc145da45
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.1.ebuild,v 1.1 2008/01/03 21:54:28 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.07"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+IUSE="doc +ocamlopt"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ emake all || die "failed to build"
+ if use ocamlopt; then
+ emake opt || die "failed to build"
+ fi
+
+ if use doc; then
+ emake doc || die "failed to create documentation"
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}
diff --git a/dev-ml/extlib/files/digest-extlib-1.5.1 b/dev-ml/extlib/files/digest-extlib-1.5.1
new file mode 100644
index 000000000000..495e03d8d815
--- /dev/null
+++ b/dev-ml/extlib/files/digest-extlib-1.5.1
@@ -0,0 +1,3 @@
+MD5 8dc2944cbf63141347956bd353893d75 extlib-1.5.1.tar.gz 70363
+RMD160 0cd77387ed46429c478fdf44e05faedd9f960751 extlib-1.5.1.tar.gz 70363
+SHA256 637cf3331d49ba00e7ebdb762c2a231603fe0dd57ad45a6cde30884a5348525e extlib-1.5.1.tar.gz 70363