summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-13 19:50:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-13 19:50:06 +0000
commiteea6f73b5b2110cbd0098a84d2ac76fb65d5e23d (patch)
treec6eb50f0ef119071f1a7b3b84a173ce464c7742e /dev-ml
parentClean up old revision. (diff)
downloadgentoo-2-eea6f73b5b2110cbd0098a84d2ac76fb65d5e23d.tar.gz
gentoo-2-eea6f73b5b2110cbd0098a84d2ac76fb65d5e23d.tar.bz2
gentoo-2-eea6f73b5b2110cbd0098a84d2ac76fb65d5e23d.zip
version bump, bug #446726 by Jacques-Pascal Deplaix
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tyxml/ChangeLog9
-rw-r--r--dev-ml/tyxml/tyxml-2.2.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-ml/tyxml/ChangeLog b/dev-ml/tyxml/ChangeLog
index 5ff9efef7fd9..51eeb1f62cff 100644
--- a/dev-ml/tyxml/ChangeLog
+++ b/dev-ml/tyxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/tyxml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/tyxml/ChangeLog,v 1.5 2012/08/07 16:38:14 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/tyxml/ChangeLog,v 1.6 2013/01/13 19:50:06 aballier Exp $
+
+*tyxml-2.2.0 (13 Jan 2013)
+
+ 13 Jan 2013; Alexis Ballier <aballier@gentoo.org> +tyxml-2.2.0.ebuild:
+ version bump, bug #446726 by Jacques-Pascal Deplaix
07 Aug 2012; Alexis Ballier <aballier@gentoo.org> -tyxml-2.0.2.ebuild,
-tyxml-2.1.ebuild:
diff --git a/dev-ml/tyxml/tyxml-2.2.0.ebuild b/dev-ml/tyxml/tyxml-2.2.0.ebuild
new file mode 100644
index 000000000000..808e7e60866d
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-2.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/tyxml/tyxml-2.2.0.ebuild,v 1.1 2013/01/13 19:50:06 aballier Exp $
+
+EAPI=4
+
+inherit eutils findlib
+
+DESCRIPTION="A libary to build xml trees typechecked by OCaml"
+HOMEPAGE="http://ocsigen.org/tyxml/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc ocamlduce +ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/ocamlnet
+ ocamlduce? ( dev-ml/ocamlduce )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ export myopts="OCAMLDUCE=$(usex ocamlduce yes no)"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake "$myopts"
+ else
+ emake "$myopts" byte
+ fi
+ use doc && emake doc "$myopts"
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake DESTIR="${D}" "$myopts" install
+ else
+ emake DESTIR="${D}" "$myopts" install-byte
+ fi
+ dodoc CHANGES README
+ use doc && dohtml -r doc/api-html
+}