summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-18 17:28:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-18 17:28:15 +0000
commitde4b560b30c57c32318c315ef0cc01040e1a899b (patch)
tree2e771c180b2f12c1146625085265359f275121e6 /dev-ml
parentversion bump (diff)
downloadgentoo-2-de4b560b30c57c32318c315ef0cc01040e1a899b.tar.gz
gentoo-2-de4b560b30c57c32318c315ef0cc01040e1a899b.tar.bz2
gentoo-2-de4b560b30c57c32318c315ef0cc01040e1a899b.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog8
-rw-r--r--dev-ml/async/async-112.24.00.ebuild39
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index cb2f8fa896e5..b8435b110dd1 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.17 2015/02/20 17:48:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.18 2015/03/18 17:28:15 aballier Exp $
+
+*async-112.24.00 (18 Mar 2015)
+
+ 18 Mar 2015; Alexis Ballier <aballier@gentoo.org> +async-112.24.00.ebuild:
+ version bump
20 Feb 2015; Alexis Ballier <aballier@gentoo.org> -async-110.01.00.ebuild,
-async-111.25.00.ebuild, -async-112.01.00.ebuild, -async-112.06.00.ebuild:
@@ -81,4 +86,3 @@
06 Mar 2013; Alexis Ballier <aballier@gentoo.org> +async-109.11.00.ebuild,
+metadata.xml:
initial import, ebuild by me
-
diff --git a/dev-ml/async/async-112.24.00.ebuild b/dev-ml/async/async-112.24.00.ebuild
new file mode 100644
index 000000000000..a80936f44e42
--- /dev/null
+++ b/dev-ml/async/async-112.24.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-112.24.00.ebuild,v 1.1 2015/03/18 17:28:15 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}