summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-22 15:54:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-22 15:54:43 +0000
commitc4da6d646094b903598600a51bd16ff333684564 (patch)
tree7d19ccc254bf733895eb6306387db9859d455d18 /dev-ml
parentAdded patch to fix build with libssh-0.4, also updated deps, this package dep... (diff)
downloadgentoo-2-c4da6d646094b903598600a51bd16ff333684564.tar.gz
gentoo-2-c4da6d646094b903598600a51bd16ff333684564.tar.bz2
gentoo-2-c4da6d646094b903598600a51bd16ff333684564.zip
Add gtksourceview2 support and use it instead of 1.x versions; patch by Rafał Mużyło <galtgendo@o2.pl>, bug #295515
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgtk/ChangeLog9
-rw-r--r--dev-ml/lablgtk/files/lablgtk-2.14.0-sourceview2.patch64
-rw-r--r--dev-ml/lablgtk/lablgtk-2.14.0-r1.ebuild85
3 files changed, 157 insertions, 1 deletions
diff --git a/dev-ml/lablgtk/ChangeLog b/dev-ml/lablgtk/ChangeLog
index f34da862f22d..1cb05501ad7a 100644
--- a/dev-ml/lablgtk/ChangeLog
+++ b/dev-ml/lablgtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/lablgtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.77 2009/12/07 08:03:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.78 2009/12/22 15:54:43 aballier Exp $
+
+*lablgtk-2.14.0-r1 (22 Dec 2009)
+
+ 22 Dec 2009; Alexis Ballier <aballier@gentoo.org>
+ +lablgtk-2.14.0-r1.ebuild, +files/lablgtk-2.14.0-sourceview2.patch:
+ Add gtksourceview2 support and use it instead of 1.x versions; patch by
+ Rafał Mużyło <galtgendo@o2.pl>, bug #295515
07 Dec 2009; Alexis Ballier <aballier@gentoo.org> -lablgtk-2.10.1.ebuild:
remove old
diff --git a/dev-ml/lablgtk/files/lablgtk-2.14.0-sourceview2.patch b/dev-ml/lablgtk/files/lablgtk-2.14.0-sourceview2.patch
new file mode 100644
index 000000000000..a79e62242c38
--- /dev/null
+++ b/dev-ml/lablgtk/files/lablgtk-2.14.0-sourceview2.patch
@@ -0,0 +1,64 @@
+--- src/gSourceView2.mli (wersja 1491)
++++ src/gSourceView2.mli (wersja 1494)
+@@ -251,7 +251,7 @@
+
+ val iter_forward_search :
+ GText.iter ->
+- SourceViewEnums.source_search_flag list ->
++ SourceView2Enums.source_search_flag list ->
+ start:< as_iter : Gtk.text_iter; .. > ->
+ stop:< as_iter : Gtk.text_iter; .. > ->
+ ?limit:< as_iter : Gtk.text_iter; .. > ->
+@@ -259,8 +259,8 @@
+
+ val iter_backward_search :
+ GText.iter ->
+- SourceViewEnums.source_search_flag list ->
++ SourceView2Enums.source_search_flag list ->
+ start:< as_iter : Gtk.text_iter; .. > ->
+ stop:< as_iter : Gtk.text_iter; .. > ->
+ ?limit:< as_iter : Gtk.text_iter; .. > ->
+- string -> (GText.iter * GText.iter) option
+\ No newline at end of file
++ string -> (GText.iter * GText.iter) option
+--- src/Makefile (wersja 1491)
++++ src/Makefile (wersja 1494)
+@@ -337,7 +337,7 @@
+ cd "$(INSTALLDIR)" && $(RANLIB) $(CLIBS)
+ cp varcc$(XE) propcc$(XE) "$(INSTALLDIR)"
+ if test $(THREADS_LIB) != no; \
+- then cp $(ALLTHOBJS:.cmo=.cmi) $(INSTALLDIR); \
++ then cp $(ALLTHOBJS:.cmo=.cmi) "$(INSTALLDIR)"; \
+ fi
+ if test $(THREADS_LIB) = vm || test $(HAS_DLL_SUPPORT) != yes; \
+ then cp lablgtktop$(XE) "$(INSTALLDIR)"; \
+--- src/ml_gtktree.c (wersja 1491)
++++ src/ml_gtktree.c (wersja 1494)
+@@ -684,6 +684,7 @@
+ ML_2 (gtk_tree_view_set_tooltip_column, GtkTreeView_val, Int_val, Unit)
+ #else
+ Unsupported_212 (gtk_tree_view_set_tooltip_cell)
++Unsupported_212 (gtk_tree_view_set_tooltip_cell_bc)
+ Unsupported_212 (gtk_tree_view_set_tooltip_row)
+ Unsupported_212 (gtk_tree_view_get_tooltip_context)
+ Unsupported_212 (gtk_tree_view_get_tooltip_column)
+--- src/gtkSourceView2.ml (wersja 1491)
++++ src/gtkSourceView2.ml (wersja 1494)
+@@ -189,13 +189,13 @@
+ module SourceViewMisc =
+ struct
+ external iter_backward_search:
+- Gtk.text_iter -> string -> SourceViewEnums.source_search_flag list ->
++ Gtk.text_iter -> string -> SourceView2Enums.source_search_flag list ->
+ start: Gtk.text_iter -> stop: Gtk.text_iter -> Gtk.text_iter option ->
+ (Gtk.text_iter * Gtk.text_iter) option =
+ "ml_gtk_source_iter_backward_search_bc" "ml_gtk_source_iter_backward_search"
+ external iter_forward_search:
+- Gtk.text_iter -> string -> SourceViewEnums.source_search_flag list ->
++ Gtk.text_iter -> string -> SourceView2Enums.source_search_flag list ->
+ start: Gtk.text_iter -> stop: Gtk.text_iter -> Gtk.text_iter option ->
+ (Gtk.text_iter * Gtk.text_iter) option =
+ "ml_gtk_source_iter_forward_search_bc" "ml_gtk_source_iter_forward_search"
+-end
+\ No newline at end of file
++end
diff --git a/dev-ml/lablgtk/lablgtk-2.14.0-r1.ebuild b/dev-ml/lablgtk/lablgtk-2.14.0-r1.ebuild
new file mode 100644
index 000000000000..99b117c85738
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.14.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/lablgtk-2.14.0-r1.ebuild,v 1.1 2009/12/22 15:54:43 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+IUSE="debug examples glade gnome gnomecanvas sourceview +ocamlopt opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html"
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+LICENSE="LGPL-2.1 as-is"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-lang/ocaml-3.10[ocamlopt?]
+ svg? ( >=gnome-base/librsvg-2.2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ gnome? ( >=gnome-base/gnome-panel-2.4.0
+ >=gnome-base/libgnomeui-2.4.0 )
+ opengl? ( >=dev-ml/lablgl-0.98
+ >=x11-libs/gtkglarea-1.9 )
+ spell? ( app-text/gtkspell )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-sourceview2.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ $(use_with gnome gnomeui) \
+ $(use_with gnome panel) \
+ $(use_with opengl gl) \
+ $(use_with spell gtkspell) \
+ --without-gtksourceview \
+ $(use_with sourceview gtksourceview2) \
+ $(use_with gnomecanvas)
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code failed"
+ fi
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+ # Install examples for optional components
+ use gnomecanvas && insinto /usr/share/doc/${P}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+ use svg && insinto /usr/share/doc/${P}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+ use glade && insinto /usr/share/doc/${P}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+ use sourceview && insinto /usr/share/doc/${P}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+ use opengl && insinto /usr/share/doc/${P}/examples/GL && doins examples/GL/*.ml
+ use gnome && insinto /usr/share/doc/${P}/examples/panel && doins examples/panel/*
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die
+
+ # ocamlfind support
+ insinto /usr/$(get_libdir)/ocaml/lablgtk2
+ doins META
+
+ dodoc CHANGES README CHANGES.API
+ use examples && install_examples
+}
+
+pkg_postinst () {
+ use examples && elog "To run the examples you can use the lablgtk2 toplevel."
+ use examples && elog "e.g: lablgtk2 /usr/share/doc/${P}/examples/testgtk.ml"
+}