summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-10 08:31:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-10 08:31:26 +0000
commita9bf00bab1521e7eaecaf58d9ed73dc6219ed852 (patch)
tree595e365bb7d0feb9f300beb62abb97dce933c36a /dev-ml
parentversion bump (diff)
downloadgentoo-2-a9bf00bab1521e7eaecaf58d9ed73dc6219ed852.tar.gz
gentoo-2-a9bf00bab1521e7eaecaf58d9ed73dc6219ed852.tar.bz2
gentoo-2-a9bf00bab1521e7eaecaf58d9ed73dc6219ed852.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/core/ChangeLog8
-rw-r--r--dev-ml/core/core-111.28.00.ebuild41
-rw-r--r--dev-ml/core/files/glibc220.patch13
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 474cc195299a..8755931a3f06 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.28 2014/02/13 15:44:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.29 2014/11/10 08:31:26 aballier Exp $
+
+*core-111.28.00 (10 Nov 2014)
+
+ 10 Nov 2014; Alexis Ballier <aballier@gentoo.org> +core-111.28.00.ebuild,
+ +files/glibc220.patch:
+ version bump
*core-110.01.00 (13 Feb 2014)
diff --git a/dev-ml/core/core-111.28.00.ebuild b/dev-ml/core/core-111.28.00.ebuild
new file mode 100644
index 000000000000..46cac5d89fed
--- /dev/null
+++ b/dev-ml/core/core-111.28.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-111.28.00.ebuild,v 1.1 2014/11/10 08:31:26 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ dev-ml/custom_printf:=
+ dev-ml/pa_bench:=
+ dev-ml/pa_test:=
+ dev-ml/enumerate:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )
+
+PATCHES=( "${FILESDIR}/glibc220.patch" )
diff --git a/dev-ml/core/files/glibc220.patch b/dev-ml/core/files/glibc220.patch
new file mode 100644
index 000000000000..7e4f70f6c1e4
--- /dev/null
+++ b/dev-ml/core/files/glibc220.patch
@@ -0,0 +1,13 @@
+Index: core-111.28.00/lib/unix_stubs.c
+===================================================================
+--- core-111.28.00.orig/lib/unix_stubs.c
++++ core-111.28.00/lib/unix_stubs.c
+@@ -434,7 +434,7 @@ static value core_stat_aux_64(struct sta
+ CAMLparam0();
+ CAMLlocal5(atime, mtime, ctime, offset, v);
+
+- #if defined _BSD_SOURCE || defined _SVID_SOURCE
++ #if defined _BSD_SOURCE || defined _SVID_SOURCE || (_POSIX_C_SOURCE - 0) >= 200809L || (_XOPEN_SOURCE - 0) >= 700
+ atime = caml_copy_double((double) buf->st_atime + (buf->st_atim.tv_nsec / 1000000000.0f));
+ mtime = caml_copy_double((double) buf->st_mtime + (buf->st_mtim.tv_nsec / 1000000000.0f));
+ ctime = caml_copy_double((double) buf->st_ctime + (buf->st_ctim.tv_nsec / 1000000000.0f));