summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-04 01:38:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-04 01:38:29 +0000
commit7fa574ef04fe2f596cc92fc9a63f2440ef482c68 (patch)
tree1f6b0fbde0c8945aa49176a68278a298685bb478 /dev-ml
parent~amd64, working fine here (diff)
downloadgentoo-2-7fa574ef04fe2f596cc92fc9a63f2440ef482c68.tar.gz
gentoo-2-7fa574ef04fe2f596cc92fc9a63f2440ef482c68.tar.bz2
gentoo-2-7fa574ef04fe2f596cc92fc9a63f2440ef482c68.zip
allow building without ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit/ChangeLog7
-rw-r--r--dev-ml/ounit/ounit-1.0.2.ebuild24
2 files changed, 24 insertions, 7 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 60e6f03a4882..4c83fd3f5ff8 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ounit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.7 2007/05/12 22:41:01 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.8 2008/01/04 01:38:29 aballier Exp $
+
+ 04 Jan 2008; Alexis Ballier <aballier@gentoo.org> ounit-1.0.2.ebuild:
+ allow building without ocamlopt
*ounit-1.0.2 (12 May 2007)
diff --git a/dev-ml/ounit/ounit-1.0.2.ebuild b/dev-ml/ounit/ounit-1.0.2.ebuild
index cc529ca8e622..e5c5717b3123 100644
--- a/dev-ml/ounit/ounit-1.0.2.ebuild
+++ b/dev-ml/ounit/ounit-1.0.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.2.ebuild,v 1.1 2007/05/12 22:41:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.2.ebuild,v 1.2 2008/01/04 01:38:29 aballier Exp $
-inherit findlib
+inherit findlib eutils
+
+EAPI="1"
DESCRIPTION="Unit testing framework for OCaml"
HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
@@ -11,10 +13,22 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
DEPEND="dev-lang/ocaml"
-IUSE=""
+IUSE="+ocamlopt"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
src_compile() {
- emake all allopt || die "emake failed"
+ emake all || die "emake failed"
+ if use ocamlopt; then
+ emake allopt || die "failed to build native code"
+ fi
}
src_install() {