summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-25 23:18:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-25 23:18:27 +0000
commit5b7188c897a214a0904d10bc95836bbc95dc74b1 (patch)
tree5d82b57542e0902b64c742418e6d3d9f80c53630 /dev-ml
parentFix zlib dep. (diff)
downloadgentoo-2-5b7188c897a214a0904d10bc95836bbc95dc74b1.tar.gz
gentoo-2-5b7188c897a214a0904d10bc95836bbc95dc74b1.tar.bz2
gentoo-2-5b7188c897a214a0904d10bc95836bbc95dc74b1.zip
version bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog9
-rw-r--r--dev-ml/findlib/findlib-1.2.8.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 81d7e30357ae..2747aec0dff7 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.80 2011/10/11 19:36:03 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.81 2012/02/25 23:18:27 aballier Exp $
+
+*findlib-1.2.8 (25 Feb 2012)
+
+ 25 Feb 2012; Alexis Ballier <aballier@gentoo.org> +findlib-1.2.8.ebuild:
+ version bump
11 Oct 2011; Alexis Ballier <aballier@gentoo.org> -findlib-1.2.6.ebuild:
remove old
diff --git a/dev-ml/findlib/findlib-1.2.8.ebuild b/dev-ml/findlib/findlib-1.2.8.ebuild
new file mode 100644
index 000000000000..f752a024d501
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.2.8.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.8.ebuild,v 1.1 2012/02/25 23:18:27 aballier Exp $
+
+EAPI=2
+
+inherit multilib
+
+RESTRICT="installsources"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die
+ if use ocamlopt; then
+ emake opt || die # optimized code
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ emake prefix="${D}" install || die
+
+ dodir "${stublibs}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}