summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-06 20:09:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-06 20:09:37 +0000
commit591bb2cc13d5842722cd2194c0a5902d6e43fbed (patch)
tree80b55bfb238cb1d6324f513cb62e49b808541340 /dev-ml
parentremove forgotten ptex dep in previous commit (diff)
downloadgentoo-2-591bb2cc13d5842722cd2194c0a5902d6e43fbed.tar.gz
gentoo-2-591bb2cc13d5842722cd2194c0a5902d6e43fbed.tar.bz2
gentoo-2-591bb2cc13d5842722cd2194c0a5902d6e43fbed.zip
version bump
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bin-prot/ChangeLog7
-rw-r--r--dev-ml/bin-prot/bin-prot-2.0.3.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index 1d89ca657b5c..0af5242d40dc 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.10 2011/07/06 18:25:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.11 2011/10/06 20:09:37 aballier Exp $
+
+*bin-prot-2.0.3 (06 Oct 2011)
+
+ 06 Oct 2011; Alexis Ballier <aballier@gentoo.org> +bin-prot-2.0.3.ebuild:
+ version bump
06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -bin-prot-1.2.24.ebuild,
-bin-prot-1.3.0.ebuild:
diff --git a/dev-ml/bin-prot/bin-prot-2.0.3.ebuild b/dev-ml/bin-prot/bin-prot-2.0.3.ebuild
new file mode 100644
index 000000000000..63bf64c5145d
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-2.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-2.0.3.ebuild,v 1.1 2011/10/06 20:09:37 aballier Exp $
+
+EAPI=3
+
+EAPI="2"
+
+inherit findlib eutils multilib
+
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/findlib
+ >=dev-ml/ounit-1.0.2
+ >=dev-ml/type-conv-2.3.0"
+DEPEND="${RDEPEND}
+ >=dev-ml/ounit-1.0.2
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}