summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-12 12:36:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-12 12:36:35 +0000
commit5476b773eba9336c9b978dab406ad6d3994dd99b (patch)
tree5d699a54aee4f996614f095a09873875a559b4aa /dev-ml
parentStable for HPPA (bug #196735). (diff)
downloadgentoo-2-5476b773eba9336c9b978dab406ad6d3994dd99b.tar.gz
gentoo-2-5476b773eba9336c9b978dab406ad6d3994dd99b.tar.bz2
gentoo-2-5476b773eba9336c9b978dab406ad6d3994dd99b.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/files/digest-findlib-1.23
-rw-r--r--dev-ml/findlib/findlib-1.2.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index 319f3eacb703..0416173b5d29 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.24 2007/08/30 13:33:52 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.25 2007/11/12 12:36:34 aballier Exp $
+
+*findlib-1.2 (12 Nov 2007)
+
+ 12 Nov 2007; Alexis Ballier <aballier@gentoo.org> +findlib-1.2.ebuild:
+ version bump
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing mattam from metadata due to his retirement (see #30021 for reference).
diff --git a/dev-ml/findlib/files/digest-findlib-1.2 b/dev-ml/findlib/files/digest-findlib-1.2
new file mode 100644
index 000000000000..2e9e34d648d5
--- /dev/null
+++ b/dev-ml/findlib/files/digest-findlib-1.2
@@ -0,0 +1,3 @@
+MD5 07fc67a38be98ca7e20ec1d38cfdc526 findlib-1.2.tar.gz 158466
+RMD160 cb03681ec618c27472c6da776aedde00db7f4cc5 findlib-1.2.tar.gz 158466
+SHA256 5f44b50da77e82a16bb6aa556aaa087f8a5f3b9dbcbcc179978788be6da5f5e6 findlib-1.2.tar.gz 158466
diff --git a/dev-ml/findlib/findlib-1.2.ebuild b/dev-ml/findlib/findlib-1.2.ebuild
new file mode 100644
index 000000000000..42d8755251b2
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.ebuild,v 1.1 2007/11/12 12:36:34 aballier Exp $
+
+inherit multilib eutils
+
+IUSE="doc tk"
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://www.ocaml-programming.de/packages/"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="MIT X11"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.07"
+
+ocamlfind_destdir="/usr/$(get_libdir)/ocaml/site-packages"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+pkg_setup()
+{
+ if ( use tk && ! built_with_use dev-lang/ocaml tk ); then
+ eerror "It seems you don't have ocaml compiled with tk support"
+ eerror ""
+ eerror "The findlib toolbox requires ocaml be built with tk support."
+ eerror ""
+ die "Please make sure that ocaml is installed with tk support or remove the USE flag"
+ fi
+}
+
+src_compile() {
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf || die "configure failed"
+
+ emake all || die
+ emake opt || die # optimized code
+}
+
+src_install() {
+ dodir `ocamlc -where`
+
+ emake prefix="${D}" install || die
+
+ dodir "${stublibs}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}