summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-12 12:43:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-12 12:43:52 +0000
commit1df57cf0b6bc97e73b2e71c68218612a852618f3 (patch)
treee136b495144a2344a7fcbb07987bff23e7014576 /dev-ml
parentVersion bump, add animations, update WUnderground parser (diff)
downloadgentoo-2-1df57cf0b6bc97e73b2e71c68218612a852618f3.tar.gz
gentoo-2-1df57cf0b6bc97e73b2e71c68218612a852618f3.tar.bz2
gentoo-2-1df57cf0b6bc97e73b2e71c68218612a852618f3.zip
remove old
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog5
-rw-r--r--dev-ml/findlib/findlib-1.2.2.ebuild92
2 files changed, 4 insertions, 93 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index febe4e6293e1..01e1e2b57b89 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/findlib
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.53 2009/01/12 04:15:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.54 2009/01/12 12:43:52 aballier Exp $
+
+ 12 Jan 2009; Alexis Ballier <aballier@gentoo.org> -findlib-1.2.2.ebuild:
+ remove old
12 Jan 2009; Jeroen Roovers <jer@gentoo.org> findlib-1.2.3.ebuild:
Stable for HPPA (bug #254069).
diff --git a/dev-ml/findlib/findlib-1.2.2.ebuild b/dev-ml/findlib/findlib-1.2.2.ebuild
deleted file mode 100644
index b485bef48b9f..000000000000
--- a/dev-ml/findlib/findlib-1.2.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.2.ebuild,v 1.8 2008/09/30 17:44:16 jer Exp $
-
-inherit multilib eutils
-
-EAPI="1"
-
-IUSE="doc +ocamlopt tk"
-
-RESTRICT="installsources"
-
-DESCRIPTION="OCaml tool to find/use non-standard packages."
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-
-LICENSE="MIT X11"
-
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-DEPEND=">=dev-lang/ocaml-3.07"
-
-ocamlfind_destdir="/usr/$(get_libdir)/ocaml/site-packages"
-stublibs="${ocamlfind_destdir}/stublibs"
-
-pkg_setup()
-{
- if ( use tk && ! built_with_use dev-lang/ocaml tk ); then
- eerror "It seems you don't have ocaml compiled with tk support"
- eerror ""
- eerror "The findlib toolbox requires ocaml be built with tk support."
- eerror ""
- die "Please make sure that ocaml is installed with tk support or remove the USE flag"
- fi
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_compile() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir /usr/bin -mandir /usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- ${myconf} || die "configure failed"
-
- emake all || die
- if use ocamlopt; then
- emake opt || die # optimized code
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
- fi
-}
-
-src_install() {
- dodir `ocamlc -where`
-
- emake prefix="${D}" install || die
-
- dodir "${stublibs}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}