summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-09 11:24:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-09 11:24:50 +0000
commit13e4ee00e90aa51afe9e58a10c8e4de111084d69 (patch)
tree77b42ee60c9acce9ecf81f9ae446ab420b6fc703 /dev-ml
parentClass-XSAccessor-Array was merged into Class-XSAccessor-1.05 (#275520) (diff)
downloadgentoo-2-13e4ee00e90aa51afe9e58a10c8e4de111084d69.tar.gz
gentoo-2-13e4ee00e90aa51afe9e58a10c8e4de111084d69.tar.bz2
gentoo-2-13e4ee00e90aa51afe9e58a10c8e4de111084d69.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog9
-rw-r--r--dev-ml/camlp5/camlp5-5.13.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index d97b6e8a292c..e262878d530c 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.40 2009/09/20 13:27:31 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.41 2010/04/09 11:24:50 aballier Exp $
+
+*camlp5-5.13 (09 Apr 2010)
+
+ 09 Apr 2010; Alexis Ballier <aballier@gentoo.org> +camlp5-5.13.ebuild:
+ version bump
20 Sep 2009; Alexis Ballier <aballier@gentoo.org> -camlp5-5.11.ebuild:
remove old
diff --git a/dev-ml/camlp5/camlp5-5.13.ebuild b/dev-ml/camlp5/camlp5-5.13.ebuild
new file mode 100644
index 000000000000..ac0e768cc92e
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.13.ebuild,v 1.1 2010/04/09 11:24:50 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}