summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-07 14:04:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-07 14:04:03 +0000
commit1168eb292c4220100ef76c104ab09b901f2114de (patch)
treee2debdcb6d78b7cc04608dd2af9ef747112615ba /dev-ml
parentmask new sexplib (diff)
downloadgentoo-2-1168eb292c4220100ef76c104ab09b901f2114de.tar.gz
gentoo-2-1168eb292c4220100ef76c104ab09b901f2114de.tar.bz2
gentoo-2-1168eb292c4220100ef76c104ab09b901f2114de.zip
version bump
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/sexplib/ChangeLog7
-rw-r--r--dev-ml/sexplib/sexplib-7.0.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index 7c1d25cce01f..6b2d6b08930b 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.9 2011/07/23 15:44:59 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.10 2011/09/07 14:04:03 aballier Exp $
+
+*sexplib-7.0.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexis Ballier <aballier@gentoo.org> +sexplib-7.0.1.ebuild:
+ version bump
23 Jul 2011; Thomas Kahle <tomka@gentoo.org> sexplib-5.2.1.ebuild:
~x86 per bug 373149
diff --git a/dev-ml/sexplib/sexplib-7.0.1.ebuild b/dev-ml/sexplib/sexplib-7.0.1.ebuild
new file mode 100644
index 000000000000..46ca2f4ca5a1
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-7.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-7.0.1.ebuild,v 1.1 2011/09/07 14:04:03 aballier Exp $
+
+EAPI=3
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://forge.ocamlcore.org/projects/sexplib/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/670/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/type-conv-2.3.0"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}