summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-22 13:08:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-22 13:08:53 +0000
commitf4ee11809e3288cad6336ab065ec9af11f9ad291 (patch)
treee4e095fc6a947b8ca81ab925b0b35c6981b4114d /dev-ml/ocurl
parentversion bump (diff)
downloadgentoo-2-f4ee11809e3288cad6336ab065ec9af11f9ad291.tar.gz
gentoo-2-f4ee11809e3288cad6336ab065ec9af11f9ad291.tar.bz2
gentoo-2-f4ee11809e3288cad6336ab065ec9af11f9ad291.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocurl')
-rw-r--r--dev-ml/ocurl/ChangeLog7
-rw-r--r--dev-ml/ocurl/ocurl-0.5.6.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index e497dcd2af3b..2aa2d858ddeb 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocurl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.14 2013/07/22 12:34:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.15 2013/07/22 13:08:53 aballier Exp $
+
+*ocurl-0.5.6 (22 Jul 2013)
+
+ 22 Jul 2013; Alexis Ballier <aballier@gentoo.org> +ocurl-0.5.6.ebuild:
+ version bump
22 Jul 2013; Alexis Ballier <aballier@gentoo.org> -ocurl-0.2.1.ebuild,
-ocurl-0.5.1.ebuild:
diff --git a/dev-ml/ocurl/ocurl-0.5.6.ebuild b/dev-ml/ocurl/ocurl-0.5.6.ebuild
new file mode 100644
index 000000000000..9ca48c9fadbb
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.5.6.ebuild,v 1.1 2013/07/22 13:08:53 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/"
+LICENSE="MIT"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1134/${P}.tgz"
+
+SLOT="0/${PV}"
+IUSE="examples"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake -j1 all
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc CHANGES.txt README
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}