summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-06-22 12:42:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-06-22 12:42:30 +0000
commitaf9c9ca747d57be0ad639eb38d79e224d8a7b8bc (patch)
tree3ee4bb4c91e8cd7753e4f46c9930935b4b103708 /dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild
parentStable gnustep-base does not have USE=libobjc2, thanks ago (diff)
downloadgentoo-2-af9c9ca747d57be0ad639eb38d79e224d8a7b8bc.tar.gz
gentoo-2-af9c9ca747d57be0ad639eb38d79e224d8a7b8bc.tar.bz2
gentoo-2-af9c9ca747d57be0ad639eb38d79e224d8a7b8bc.zip
version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild')
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild
new file mode 100644
index 000000000000..a11a7586c757
--- /dev/null
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.0.ebuild,v 1.1 2012/06/22 12:42:30 aballier Exp $
+
+inherit findlib
+
+DESCRIPTION="OCaml SDL Bindings"
+
+HOMEPAGE="http://ocamlsdl.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc opengl truetype" #noimage nomixer
+
+DEPEND=">=dev-lang/ocaml-3.04
+>=media-libs/libsdl-1.2
+opengl? ( >=dev-ml/lablgl-0.98 )
+>=media-libs/sdl-mixer-1.2
+>=media-libs/sdl-image-1.2
+truetype? ( >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ myconf=""
+ if use opengl; then
+ destdir=`ocamlfind printconf destdir`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ if [ -z "${lablgldir}" ]; then
+ destdir=`ocamlc -where`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ fi
+
+ if [ ! -z "${lablgldir}" ]; then
+ myconf="--with-lablgldir=${lablgldir}"
+ fi
+ fi
+
+ #use noimage && myconf="${myconf} --without-sdl-image"
+ #use nomixer && myconf="${myconf} --without-sdl-mixer"
+
+ econf $myconf \
+ `use_enable truetype sdl-ttf` \
+ || die
+ emake all || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc AUTHORS NEWS README || die
+ doinfo doc/*.info* || die
+
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+}