summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 13:51:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 13:51:29 +0000
commitd3a9f42be613cee3d28a72c4e331937adf05c30e (patch)
tree2941b712c21424942c08f32676206de383ac14d0 /dev-ml/ocamlgsl
parentremove old (diff)
downloadgentoo-2-d3a9f42be613cee3d28a72c4e331937adf05c30e.tar.gz
gentoo-2-d3a9f42be613cee3d28a72c4e331937adf05c30e.tar.bz2
gentoo-2-d3a9f42be613cee3d28a72c4e331937adf05c30e.zip
eapi5, define subslot and add := dep on ocaml packages
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlgsl')
-rw-r--r--dev-ml/ocamlgsl/ChangeLog7
-rw-r--r--dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild18
2 files changed, 14 insertions, 11 deletions
diff --git a/dev-ml/ocamlgsl/ChangeLog b/dev-ml/ocamlgsl/ChangeLog
index db841277964d..bd550f756555 100644
--- a/dev-ml/ocamlgsl/ChangeLog
+++ b/dev-ml/ocamlgsl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlgsl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ChangeLog,v 1.5 2011/02/12 16:02:42 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ChangeLog,v 1.6 2013/08/19 13:51:29 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocamlgsl-0.6.0.ebuild:
+ eapi5, define subslot and add := dep on ocaml packages
12 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> ocamlgsl-0.6.0.ebuild:
Marked ~ppc wrt #322673
diff --git a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
index 62cd29e18652..17b7c980f861 100644
--- a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
+++ b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild,v 1.5 2011/02/12 16:02:42 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild,v 1.6 2013/08/19 13:51:29 aballier Exp $
-EAPI="2"
+EAPI=5
inherit base findlib
@@ -11,11 +11,11 @@ HOMEPAGE="http://oandrieu.nerim.net/ocaml/gsl/"
SRC_URI="http://oandrieu.nerim.net/ocaml/gsl/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="amd64 ~ppc x86"
IUSE="doc test"
-RDEPEND=">=dev-lang/ocaml-3.10
+RDEPEND=">=dev-lang/ocaml-3.10:=
sci-libs/gsl"
DEPEND="${RDEPEND}
test? ( dev-ml/fort )"
@@ -23,16 +23,16 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${P}-ocaml311.patch" )
src_compile() {
- emake CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CFLAGS="${CFLAGS}"
}
src_install() {
findlib_src_preinst
- emake install-findlib || die "emake install failed"
+ emake install-findlib
dodoc README NEWS NOTES
- doinfo *.info* || die "info install failed"
+ doinfo *.info*
if use doc; then
- dohtml doc/* || die "html docs install failed"
+ dohtml doc/*
fi
}