summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-23 12:21:18 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-23 12:21:18 +0000
commit80850908247c36882b2aba8c94b63a28ead88a1a (patch)
tree9c07a5a1b894e79100a2443804b1488c8dcf48f3 /dev-ml/facile/facile-1.1.ebuild
parentRemove old. (diff)
downloadgentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.tar.gz
gentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.tar.bz2
gentoo-2-80850908247c36882b2aba8c94b63a28ead88a1a.zip
Fix building on non GNU platforms and keyword ~x86-fbsd, #192065
(Portage version: 2.1.3.15)
Diffstat (limited to 'dev-ml/facile/facile-1.1.ebuild')
-rw-r--r--dev-ml/facile/facile-1.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
index c55d424669ae..6f2b3c2bd770 100644
--- a/dev-ml/facile/facile-1.1.ebuild
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.5 2007/10/13 10:26:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.6 2007/10/23 12:21:18 uberlord Exp $
+
+inherit eutils
DESCRIPTION="FaCiLe is a constraint programming library on integer and integer set finite domains written in OCaml."
HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
@@ -16,6 +18,14 @@ IUSE=""
DEPEND=">=dev-lang/ocaml-3.09.3-r1"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix building on FreeBSD
+ epatch "${FILESDIR}/${P}"-make.patch
+}
+
src_compile(){
# This is a custom configure script and it does not support standard options
./configure --faciledir ${D}$(ocamlc -where)/facile/