summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-02-08 15:48:18 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-02-08 15:48:18 +0000
commit2cf5ae195f88b809f2cd73478406abf750bea869 (patch)
treed65a4daa101d438df12d67e7deefb1bb5c046db2 /dev-lua
parentadd python2 to USE too so that it is rebuilt within stage3, bug #448256 (diff)
downloadgentoo-2-2cf5ae195f88b809f2cd73478406abf750bea869.tar.gz
gentoo-2-2cf5ae195f88b809f2cd73478406abf750bea869.tar.bz2
gentoo-2-2cf5ae195f88b809f2cd73478406abf750bea869.zip
Revbump: set up propep deps (bug #445049, thanks to krigstask) and fix test with virtualx (bug #448460).
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lgi/ChangeLog10
-rw-r--r--dev-lua/lgi/lgi-0.6.2-r1.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-lua/lgi/ChangeLog b/dev-lua/lgi/ChangeLog
index 8e8bac46dcb0..28eb51fd4325 100644
--- a/dev-lua/lgi/ChangeLog
+++ b/dev-lua/lgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/lgi
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.1 2012/11/27 20:20:48 robbat2 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/ChangeLog,v 1.2 2013/02/08 15:48:18 maksbotan Exp $
+
+*lgi-0.6.2-r1 (08 Feb 2013)
+
+ 08 Feb 2013; Maxim Koltsov <maksbotan@gentoo.org> +lgi-0.6.2-r1.ebuild:
+ Revbump: set up propep deps (bug #445049, thanks to krigstask) and fix test
+ with virtualx (bug #448460).
*lgi-0.6.2 (27 Nov 2012)
diff --git a/dev-lua/lgi/lgi-0.6.2-r1.ebuild b/dev-lua/lgi/lgi-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..16b0303d73ff
--- /dev/null
+++ b/dev-lua/lgi/lgi-0.6.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lgi/lgi-0.6.2-r1.ebuild,v 1.1 2013/02/08 15:48:18 maksbotan Exp $
+
+EAPI=4
+
+VIRTUALX_REQUIRED="manual"
+
+inherit eutils toolchain-funcs flag-o-matic virtualx
+
+DESCRIPTION="Lua bindings using gobject-introspection"
+HOMEPAGE="http://github.com/pavouk/lgi"
+SRC_URI="http://github.com/downloads/pavouk/lgi/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/gobject-introspection
+ dev-libs/glib
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ x11-libs/cairo[glib]
+ x11-libs/gtk+[introspection]
+ ${VIRTUALX_DEPEND}
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
+ -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
+ "${S}"/lgi/Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
+}
+
+src_test() {
+ Xemake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dohtml -r docs/*
+ dodoc README.md
+ if use examples; then
+ dodoc -r samples
+ fi
+}