summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-09-18 17:28:56 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-09-18 17:28:56 +0000
commit87cd0718d11b86c518fe600ca26e0f4f27829167 (patch)
tree2855782fbb7b5deae2bd39dad09e9e18159a549e /dev-lisp
parentFix compile when ruby has USE="cjk". Bug #191203 thanks to : Brenden Matthews... (diff)
downloadgentoo-2-87cd0718d11b86c518fe600ca26e0f4f27829167.tar.gz
gentoo-2-87cd0718d11b86c518fe600ca26e0f4f27829167.tar.bz2
gentoo-2-87cd0718d11b86c518fe600ca26e0f4f27829167.zip
bump, fixes bug 171349, add amd64, fixes bug 192831
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/lush/ChangeLog8
-rw-r--r--dev-lisp/lush/files/aclocal.m4.patch91
-rw-r--r--dev-lisp/lush/files/digest-lush-1.2.13
-rw-r--r--dev-lisp/lush/lush-1.2.1.ebuild37
4 files changed, 138 insertions, 1 deletions
diff --git a/dev-lisp/lush/ChangeLog b/dev-lisp/lush/ChangeLog
index 25c71b74f0cf..538a54f44a97 100644
--- a/dev-lisp/lush/ChangeLog
+++ b/dev-lisp/lush/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/lush
# Copyright 2000-2007 Gentoo Foundation and Matthew Kennedy <mkennedy@gentoo.org>; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/lush/ChangeLog,v 1.10 2007/07/22 08:02:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/lush/ChangeLog,v 1.11 2007/09/18 17:28:55 hkbst Exp $
+
+*lush-1.2.1 (18 Sep 2007)
+
+ 18 Sep 2007; Marijn Schouten <hkBst@gentoo.org> +files/aclocal.m4.patch,
+ +lush-1.2.1.ebuild:
+ bump, fixes bug 171349, add amd64, fixes bug 192831
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> lush-1.0.ebuild,
lush-1.1.ebuild:
diff --git a/dev-lisp/lush/files/aclocal.m4.patch b/dev-lisp/lush/files/aclocal.m4.patch
new file mode 100644
index 000000000000..8c1a4798cac9
--- /dev/null
+++ b/dev-lisp/lush/files/aclocal.m4.patch
@@ -0,0 +1,91 @@
+--- aclocal.m4.old 2007-09-18 19:07:48.000000000 +0200
++++ aclocal.m4 2007-09-18 19:15:29.000000000 +0200
+@@ -102,49 +102,49 @@
+ [ac_cpu=$withval])
+
+ AC_ARG_VAR(OPTS, [Optimization flags for all compilers.])
+- if test x${OPTS+set} = xset ; then
+- saved_CFLAGS="$CFLAGS"
+- CFLAGS=
+- for opt in $saved_CFLAGS ; do
+- case $opt in
+- -O*|-g*) ;;
+- *) CFLAGS="$CFLAGS $opt" ;;
+- esac
+- done
+- AC_MSG_CHECKING([user provided debugging flags])
++# if test x${OPTS+set} = xset ; then
++# saved_CFLAGS="$CFLAGS"
++# CFLAGS=
++# for opt in $saved_CFLAGS ; do
++# case $opt in
++# -O*|-g*) ;;
++# *) CFLAGS="$CFLAGS $opt" ;;
++# esac
++# done
++# AC_MSG_CHECKING([user provided debugging flags])
+ AC_MSG_RESULT($OPTS)
+- else
+- saved_CFLAGS="$CFLAGS"
+- CFLAGS=
+- for opt in $saved_CFLAGS ; do
+- case $opt in
+- -O*) ;;
+- -g*) OPTS="$OPTS $opt" ;;
+- *) CFLAGS="$CFLAGS $opt" ;;
+- esac
+- done
++# else
++# saved_CFLAGS="$CFLAGS"
++# CFLAGS=
++# for opt in $saved_CFLAGS ; do
++# case $opt in
++# -O*) ;;
++# -g*) OPTS="$OPTS $opt" ;;
++# *) CFLAGS="$CFLAGS $opt" ;;
++# esac
++# done
+ if test x$ac_debug = xno ; then
+ OPTS=-DNO_DEBUG
+- AC_CHECK_CC_OPT([-Wall],[OPTS="$OPTS -Wall"])
+- AC_CHECK_CC_OPT([-O3],[OPTS="$OPTS -O3"],
+- [ AC_CHECK_CC_OPT([-O2], [OPTS="$OPTS -O2"] ) ] )
+- if test -z "$ac_cpu" ; then
+- AC_MSG_WARN([guessing cpu type (use --with-cpu=cpuname to override.)])
+- fi
+- opt="-march=${ac_cpu-${host_cpu}}"
+- AC_CHECK_CC_OPT([$opt], [OPTS="$OPTS $opt"],
+- [ opt="-mcpu=${ac_cpu-${host_cpu}}"
+- AC_CHECK_CC_OPT([$opt], [OPTS="$OPTS $opt"]) ] )
+- if test -z "$ac_cpu" -a "$host_cpu" = "i686" ; then
+- AC_CHECK_CC_OPT([-mmmx],[OPTS="$OPTS -mmmx"
+- AC_MSG_WARN([use --with-cpu=cpuname to avoid assuming that MMX works.])])
+- if test -r /proc/cpuinfo && grep -q sse /proc/cpuinfo ; then
+- AC_CHECK_CC_OPT([-msse],[OPTS="$OPTS -msse"
+- AC_MSG_WARN([use --with-cpu=cpuname to avoid assuming that SSE works.])])
+- fi
+- fi
++# AC_CHECK_CC_OPT([-Wall],[OPTS="$OPTS -Wall"])
++# AC_CHECK_CC_OPT([-O3],[OPTS="$OPTS -O3"],
++# [ AC_CHECK_CC_OPT([-O2], [OPTS="$OPTS -O2"] ) ] )
++# if test -z "$ac_cpu" ; then
++# AC_MSG_WARN([guessing cpu type (use --with-cpu=cpuname to override.)])
++# fi
++# opt="-march=${ac_cpu-${host_cpu}}"
++# AC_CHECK_CC_OPT([$opt], [OPTS="$OPTS $opt"],
++# [ opt="-mcpu=${ac_cpu-${host_cpu}}"
++# AC_CHECK_CC_OPT([$opt], [OPTS="$OPTS $opt"]) ] )
++# if test -z "$ac_cpu" -a "$host_cpu" = "i686" ; then
++# AC_CHECK_CC_OPT([-mmmx],[OPTS="$OPTS -mmmx"
++# AC_MSG_WARN([use --with-cpu=cpuname to avoid assuming that MMX works.])])
++# if test -r /proc/cpuinfo && grep -q sse /proc/cpuinfo ; then
++# AC_CHECK_CC_OPT([-msse],[OPTS="$OPTS -msse"
++# AC_MSG_WARN([use --with-cpu=cpuname to avoid assuming that SSE works.])])
++# fi
++# fi
+ fi
+- fi
++# fi
+ ])
+
+
diff --git a/dev-lisp/lush/files/digest-lush-1.2.1 b/dev-lisp/lush/files/digest-lush-1.2.1
new file mode 100644
index 000000000000..a0146d7870b9
--- /dev/null
+++ b/dev-lisp/lush/files/digest-lush-1.2.1
@@ -0,0 +1,3 @@
+MD5 04dd0caa0e59909f3f42ca95531737ae lush-1.2.1.tar.gz 4431778
+RMD160 22622b256aab3ad1712b3bbb0c2f892de017002f lush-1.2.1.tar.gz 4431778
+SHA256 1423085ef7c4ed83374333ba7a552e7f5f35add8db0c2478c8b00c96931ad8c9 lush-1.2.1.tar.gz 4431778
diff --git a/dev-lisp/lush/lush-1.2.1.ebuild b/dev-lisp/lush/lush-1.2.1.ebuild
new file mode 100644
index 000000000000..cbd50c8d60b8
--- /dev/null
+++ b/dev-lisp/lush/lush-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/lush/lush-1.2.1.ebuild,v 1.1 2007/09/18 17:28:55 hkbst Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Lush is the Lisp User Shell"
+HOMEPAGE="http://lush.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lush/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 x11-libs/libICE x11-libs/libSM )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+# cp aclocal.m4 aclocal.m4.old
+# sed "/dnl @synopsis AC_CC_OPTIMIZE/,/^])/d" -i aclocal.m4
+# sed "/.*AC_CHECK_CC_OPT.*OPTS.*/d" -i aclocal.m4
+# sed "/AC_CC_OPTIMIZE/d" -i configure.ac
+ epatch ${FILESDIR}/aclocal.m4.patch
+# diff -u aclocal.m4.old aclocal.m4
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with X X)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR=${D} install || die "emake install failed"
+}