summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:06:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-09 04:06:32 +0000
commit875bf644f777f53c94713753353ba283a9cba862 (patch)
tree6416ccdc0fb16a23477797a2d058bf0bbae38e91 /dev-lisp
parentFixing || and ! use in moznopango instance. (diff)
downloadgentoo-2-875bf644f777f53c94713753353ba283a9cba862.tar.gz
gentoo-2-875bf644f777f53c94713753353ba283a9cba862.tar.bz2
gentoo-2-875bf644f777f53c94713753353ba283a9cba862.zip
New upstream version; Remove support for Common Lisp Controller.
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.41.ebuild91
-rw-r--r--dev-lisp/clisp/files/2.41-fastcgi-Makefile-gentoo.patch16
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.413
4 files changed, 117 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 7830aa032a19..a15cd59e577a 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.54 2006/07/23 13:03:43 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.55 2006/11/09 04:06:32 mkennedy Exp $
+
+*clisp-2.41 (09 Nov 2006)
+
+ 09 Nov 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/2.41-fastcgi-Makefile-gentoo.patch, +clisp-2.41.ebuild:
+ New upstream version; Remove support for Common Lisp Controller.
23 Jul 2006; Tobias Scherbaum <dertobi123@gentoo.org> clisp-2.39.ebuild:
Added ~ppc, bug #141470
diff --git a/dev-lisp/clisp/clisp-2.41.ebuild b/dev-lisp/clisp/clisp-2.41.ebuild
new file mode 100644
index 000000000000..c1b5d494ea87
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.41.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.1 2006/11/09 04:06:32 mkennedy Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos -sparc ~x86"
+IUSE="X new-clx fastcgi pcre postgres readline zlib"
+
+RDEPEND=">=dev-libs/libsigsegv-2.4
+ >=dev-lisp/common-lisp-controller-4.27
+ sys-devel/gettext
+ virtual/tetex
+ fastcgi? ( dev-libs/fcgi )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( || ( x11-libs/libXpm virtual/x11 ) ) )"
+
+DEPEND="${RDEPEND}
+ X? ( new-clx? ( || ( ( x11-misc/imake x11-proto/xextproto ) virtual/x11 ) ) )"
+
+PROVIDE="virtual/commonlisp"
+
+pkg_setup() {
+ if use X; then
+ if use new-clx; then
+ einfo "CLISP will be built with NEW-CLX support which is a C binding to Xorg libraries."
+ else
+ einfo "CLISP will be built with MIT-CLX support."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/2.41-fastcgi-Makefile-gentoo.patch
+}
+
+src_compile() {
+ CC="$(tc-getCC)"
+ local myconf="--with-dynamic-ffi
+ --with-module=wildcard
+ --with-module=rawsock"
+ use ppc-macos || myconf="${myconf} --with-module=bindings/glibc"
+ use readline || myconf="${myconf} --with-noreadline"
+ if use X; then
+ if use new-clx; then
+ myconf="${myconf} --with-module=clx/new-clx"
+ else
+ myconf="${myconf} --with-module=clx/mit-clx"
+ fi
+ fi
+ if use postgres; then
+ myconf="${myconf} --with-module=postgresql"
+ CC="${CC} -I $(pg_config --includedir)"
+ fi
+ use fastcgi && myconf="${myconf} --with-module=fastcgi"
+ use pcre && myconf="${myconf} --with-module=pcre"
+ use zlib && myconf="${myconf} --with-module=zlib"
+ einfo "Configuring with ${myconf}"
+ ./configure --prefix=/usr ${myconf} build || die "./configure failed"
+ cd build
+ ./makemake ${myconf} >Makefile
+ emake -j1 config.lisp
+ sed -i 's,"vi","nano",g' config.lisp
+ sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
+ emake -j1 || die
+}
+
+src_install() {
+ pushd build
+ make DESTDIR=${D} prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
+ ANNOUNCE clisp.dvi clisp.html
+ chmod a+x ${D}/usr/lib/clisp/clisp-link
+ popd
+ dohtml doc/impnotes.{css,html}
+ dohtml build/clisp.html
+ dohtml doc/clisp.png
+ dodoc build/clisp.ps
+ dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}
diff --git a/dev-lisp/clisp/files/2.41-fastcgi-Makefile-gentoo.patch b/dev-lisp/clisp/files/2.41-fastcgi-Makefile-gentoo.patch
new file mode 100644
index 000000000000..9e8af6e11ca0
--- /dev/null
+++ b/dev-lisp/clisp/files/2.41-fastcgi-Makefile-gentoo.patch
@@ -0,0 +1,16 @@
+diff -ur clisp-2.41.orig/modules/fastcgi/Makefile.in clisp-2.41/modules/fastcgi/Makefile.in
+--- clisp-2.41.orig/modules/fastcgi/Makefile.in 2004-08-12 09:38:36.000000000 -0500
++++ clisp-2.41/modules/fastcgi/Makefile.in 2006-04-24 15:14:38.000000000 -0500
+@@ -23,10 +23,10 @@
+ $(CLISP) -c fastcgi.lisp
+
+ fastcgi.o: fastcgi.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I$(INCLUDES) -I.. -c fastcgi.c
+
+ fastcgi_wrappers.o: fastcgi_wrappers.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi_wrappers.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I$(INCLUDES) -I.. -c fastcgi_wrappers.c
+
+ # Make a module
+ clisp-module : all
diff --git a/dev-lisp/clisp/files/digest-clisp-2.41 b/dev-lisp/clisp/files/digest-clisp-2.41
new file mode 100644
index 000000000000..02dcb58eed4e
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.41
@@ -0,0 +1,3 @@
+MD5 3a7a00e82ebeeb72a75a032f84c36c6c clisp-2.41.tar.bz2 8319471
+RMD160 e98ee7142c01e946f242360c7495df5668694d34 clisp-2.41.tar.bz2 8319471
+SHA256 1e5f8d9b04024ae072536ae3271075c1a422c02d3997a729a6b00912ed2ae323 clisp-2.41.tar.bz2 8319471