summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-03-14 10:51:50 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-03-14 10:51:50 +0000
commit2ff0e36c7d4dbfd32cad7d35d4ad67d17d91b2c0 (patch)
tree6fd4e0043b7225fba6bd61af75c1fabc8eca5216 /dev-lisp
parentMarked 1.1.3 stable on X86; closes bug #36211 and fixes some 2.6 issues. (Man... (diff)
downloadgentoo-2-2ff0e36c7d4dbfd32cad7d35d4ad67d17d91b2c0.tar.gz
gentoo-2-2ff0e36c7d4dbfd32cad7d35d4ad67d17d91b2c0.tar.bz2
gentoo-2-2ff0e36c7d4dbfd32cad7d35d4ad67d17d91b2c0.zip
version bumped.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/gauche/ChangeLog7
-rw-r--r--dev-lisp/gauche/Manifest2
-rw-r--r--dev-lisp/gauche/files/digest-gauche-0.7.4.21
-rw-r--r--dev-lisp/gauche/gauche-0.7.4.2.ebuild65
4 files changed, 74 insertions, 1 deletions
diff --git a/dev-lisp/gauche/ChangeLog b/dev-lisp/gauche/ChangeLog
index 7d0b50d4ad49..f7b968857046 100644
--- a/dev-lisp/gauche/ChangeLog
+++ b/dev-lisp/gauche/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/gauche
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.17 2004/02/21 14:49:37 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/ChangeLog,v 1.18 2004/03/14 10:51:50 hattya Exp $
+
+*gauche-0.7.4.2 (14 Mar 2004)
+
+ 14 Mar 2004; Akinori Hattori <hattya@gentoo.org> gauche-0.7.4.2.ebuild:
+ version bumped.
21 Feb 2004; Akinori Hattori <hattya@gentoo.org> gauche-0.7.1.ebuild,
gauche-0.7.2.ebuild:
diff --git a/dev-lisp/gauche/Manifest b/dev-lisp/gauche/Manifest
index 46f7948d84a4..d0ea6c2a6e7f 100644
--- a/dev-lisp/gauche/Manifest
+++ b/dev-lisp/gauche/Manifest
@@ -1,7 +1,9 @@
MD5 a9d9e26eee0643b60b94abf5cf275a6b ChangeLog 2811
MD5 5e3022ab6d9b28b392b093b158a1d2a9 gauche-0.7.3.ebuild 1382
MD5 19fb101a137045bb79379f53e9c50929 gauche-0.7.4.1.ebuild 1198
+MD5 77b349c0c311aeaeed99db494dde1f5e gauche-0.7.4.2.ebuild 1119
MD5 681d1885ce4490fd7c2d537a30a943de metadata.xml 618
MD5 c72a63369fdb0fee8a8f45533b69fe5f files/digest-gauche-0.7.3 62
MD5 89966637512684b9b73c898b067cf740 files/digest-gauche-0.7.4.1 64
+MD5 506a28faf2e5a3d88f080e411dff706c files/digest-gauche-0.7.4.2 64
MD5 177cc4fa4c84d465bab80e5b3adb5cc1 files/gauche-gdbm-gentoo.diff 729
diff --git a/dev-lisp/gauche/files/digest-gauche-0.7.4.2 b/dev-lisp/gauche/files/digest-gauche-0.7.4.2
new file mode 100644
index 000000000000..0f8a50b62301
--- /dev/null
+++ b/dev-lisp/gauche/files/digest-gauche-0.7.4.2
@@ -0,0 +1 @@
+MD5 2efbf8953c318f7e03dc15886588a75a Gauche-0.7.4.2.tgz 2401071
diff --git a/dev-lisp/gauche/gauche-0.7.4.2.ebuild b/dev-lisp/gauche/gauche-0.7.4.2.ebuild
new file mode 100644
index 000000000000..50ed15c542a2
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.7.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.7.4.2.ebuild,v 1.1 2004/03/14 10:51:50 hattya Exp $
+
+inherit flag-o-matic
+
+IUSE="ipv6 nls"
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+RESTRICT="nomirror"
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ autoconf
+
+}
+
+src_compile() {
+
+ local myconf mycflags
+
+ use ipv6 && myconf="--enable-ipv6"
+
+ if use nls; then
+ myconf="${myconf} --enable-multibyte=utf-8"
+ else
+ myconf="${myconf} --enable-multibyte=euc-jp"
+ fi
+
+ sed -i -e "67s/\$(LIB_INSTALL_DIR)/\$(DISTDIR)\$(LIB_INSTALL_DIR)/" src/Makefile.in
+
+ strip-flags
+
+ mycflags=${CFLAGS}
+ unset CFLAGS CXXFLAGS
+
+ econf ${myconf} --enable-threads=pthreads || die
+ emake OPTFLAGS="${mycflags}" || die
+
+ make -s check || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL INSTALL.eucjp README
+
+}