summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-04 14:54:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-04 14:54:36 +0000
commit0f07038de16454fad03a387cee1a4697da189776 (patch)
tree39d6f94152b7c63cbc2b38dd70979e350fd97101 /dev-lisp
parentReplace -Wl,--no-as-needed with function from flag-o-matic eclass. (diff)
downloadgentoo-2-0f07038de16454fad03a387cee1a4697da189776.tar.gz
gentoo-2-0f07038de16454fad03a387cee1a4697da189776.tar.bz2
gentoo-2-0f07038de16454fad03a387cee1a4697da189776.zip
Replace -Wl,--no-as-needed with function from flag-o-matic eclass.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog7
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.19.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.28.ebuild4
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.31.ebuild4
6 files changed, 16 insertions, 11 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 802fd3cccc09..9648f981968f 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.160 2009/09/30 22:10:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.161 2009/10/04 14:54:36 ssuominen Exp $
+
+ 04 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> sbcl-1.0.19.ebuild,
+ sbcl-1.0.26-r10.ebuild, sbcl-1.0.27-r10.ebuild, sbcl-1.0.28.ebuild,
+ sbcl-1.0.31.ebuild:
+ Replace -Wl,--no-as-needed with function from flag-o-matic eclass.
30 Sep 2009; Markus Meier <maekke@gentoo.org> sbcl-1.0.26-r10.ebuild,
sbcl-1.0.27-r10.ebuild, sbcl-1.0.28.ebuild, sbcl-1.0.31.ebuild:
diff --git a/dev-lisp/sbcl/sbcl-1.0.19.ebuild b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
index fb7af53c4b0f..3c09c2683f05 100644
--- a/dev-lisp/sbcl/sbcl-1.0.19.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.7 2009/03/20 15:42:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.19.ebuild,v 1.8 2009/10/04 14:54:36 ssuominen Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -121,7 +121,7 @@ src_unpack() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- append-ldflags -Wl,--no-as-needed # see Bug #132992
+ append-ldflags $(no-as-needed) # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
index 6387121de2d0..25243afafd89 100644
--- a/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.4 2009/09/30 22:10:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.26-r10.ebuild,v 1.5 2009/10/04 14:54:36 ssuominen Exp $
EAPI=2
@@ -111,7 +111,7 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- append-ldflags -Wl,--no-as-needed # see Bug #132992
+ append-ldflags $(no-as-needed) # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
index 2a037ad46632..9ce2360b1908 100644
--- a/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.4 2009/09/30 22:10:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.27-r10.ebuild,v 1.5 2009/10/04 14:54:36 ssuominen Exp $
EAPI=2
@@ -111,7 +111,7 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- append-ldflags -Wl,--no-as-needed # see Bug #132992
+ append-ldflags $(no-as-needed) # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.28.ebuild b/dev-lisp/sbcl/sbcl-1.0.28.ebuild
index c7f94d4af471..31b2c38c6bbc 100644
--- a/dev-lisp/sbcl/sbcl-1.0.28.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.28.ebuild,v 1.2 2009/09/30 22:10:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.28.ebuild,v 1.3 2009/10/04 14:54:36 ssuominen Exp $
EAPI=2
@@ -109,7 +109,7 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- append-ldflags -Wl,--no-as-needed # see Bug #132992
+ append-ldflags $(no-as-needed) # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis
diff --git a/dev-lisp/sbcl/sbcl-1.0.31.ebuild b/dev-lisp/sbcl/sbcl-1.0.31.ebuild
index ba14659a2dd9..a7bb17817b89 100644
--- a/dev-lisp/sbcl/sbcl-1.0.31.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.31.ebuild,v 1.2 2009/09/30 22:10:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.31.ebuild,v 1.3 2009/10/04 14:54:36 ssuominen Exp $
EAPI=2
@@ -109,7 +109,7 @@ src_configure() {
src_compile() {
local bindir="${WORKDIR}"/sbcl-binary
- append-ldflags -Wl,--no-as-needed # see Bug #132992
+ append-ldflags $(no-as-needed) # see Bug #132992
# clear the environment to get rid of non-ASCII strings, see bug 174702
# set HOME for paludis