summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
commitf0499138e7aa5e43bdb88278d6bef3650c46e229 (patch)
treeb29a74bee14985fc7da4a51785f23c0829b3b5d5 /dev-lisp/cl-lexer
parentinitial common lisp import (diff)
downloadgentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.gz
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.bz2
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-lexer')
-rw-r--r--dev-lisp/cl-lexer/ChangeLog8
-rw-r--r--dev-lisp/cl-lexer/Manifest5
-rw-r--r--dev-lisp/cl-lexer/cl-lexer-1.ebuild35
-rw-r--r--dev-lisp/cl-lexer/files/digest-cl-lexer-12
4 files changed, 47 insertions, 3 deletions
diff --git a/dev-lisp/cl-lexer/ChangeLog b/dev-lisp/cl-lexer/ChangeLog
new file mode 100644
index 000000000000..f5cc3312c5c5
--- /dev/null
+++ b/dev-lisp/cl-lexer/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-lexer
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lexer/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-lexer-1 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-lexer/Manifest b/dev-lisp/cl-lexer/Manifest
index 0e89f668ceee..e2099f4c0479 100644
--- a/dev-lisp/cl-lexer/Manifest
+++ b/dev-lisp/cl-lexer/Manifest
@@ -1,4 +1,3 @@
-MD5 6bcca1e9ddd042e06c2b56bccd01dfc8 ChangeLog 316
-MD5 a69b77a6c53bbc36e7e3ee9432a1a044 cl-lexer-1.ebuild 844
-MD5 992cbf0615095a60a3d7d798a53f8602 cl-lexer-1.ebuild~ 789
+MD5 3e159325eed3bf06c01c86cda8b25349 ChangeLog 317
+MD5 64024bfef4b6fe51d4883af4be69de86 cl-lexer-1.ebuild 990
MD5 900fb016d089c5e600fbb6248b071b29 files/digest-cl-lexer-1 128
diff --git a/dev-lisp/cl-lexer/cl-lexer-1.ebuild b/dev-lisp/cl-lexer/cl-lexer-1.ebuild
new file mode 100644
index 000000000000..083c8846533f
--- /dev/null
+++ b/dev-lisp/cl-lexer/cl-lexer-1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lexer/cl-lexer-1.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Lexical-analyzer-generator package for Common Lisp"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html
+ http://packages.debian.org/unstable/devel/cl-lexer.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-lexer/${PN}_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-lexer/${PN}_${PV}-2.diff.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-regex"
+
+CLPACKAGE=lexer
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${WORKDIR}/${PN}_${PV}-2.diff || die
+}
+
+src_install() {
+ common-lisp-install lexer.lisp packages.lisp lexer.asd
+ common-lisp-system-symlink
+ dodoc license.txt
+ dointo examples
+ dodoc example.lisp
+}
diff --git a/dev-lisp/cl-lexer/files/digest-cl-lexer-1 b/dev-lisp/cl-lexer/files/digest-cl-lexer-1
new file mode 100644
index 000000000000..26b85907d9ac
--- /dev/null
+++ b/dev-lisp/cl-lexer/files/digest-cl-lexer-1
@@ -0,0 +1,2 @@
+MD5 e5ea7486f75b2234d40865dd983dc796 cl-lexer_1.orig.tar.gz 4275
+MD5 ac1c7d978991550f5457eb326c8401a3 cl-lexer_1-2.diff.gz 3740