summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-07 19:27:39 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-07 19:27:39 +0000
commite4ef63d663778208a1007c06655bf13ab81541ba (patch)
tree8672cbd38be1d009991b9aed83ace1b190843904 /dev-libs
parentadded egenix-mx-base dep for python support. fixes #10411 (diff)
downloadgentoo-2-e4ef63d663778208a1007c06655bf13ab81541ba.tar.gz
gentoo-2-e4ef63d663778208a1007c06655bf13ab81541ba.tar.bz2
gentoo-2-e4ef63d663778208a1007c06655bf13ab81541ba.zip
Version bump. Bug fixes in source and some configure cleanup in the
ebuild.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog8
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.12.ebuild110
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.12-kerberos.patch24
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.121
4 files changed, 142 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 9523f2106bac..b2e8189ec98a 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.32 2003/01/29 23:13:09 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.33 2003/02/07 19:27:39 raker Exp $
+
+*cyrus-sasl-2.1.12 (06 Feb 2003)
+
+ 06 Feb 2003; Nick Hadaway <raker@gentoo.org> cyrus-sasl-2.1.12.ebuild,
+ files/digest-cyrus-sasl-2.1.12, files/cyrus-sasl-2.1.12-kerberos.patch :
+ Version bump. Cleaned up some configure options.
*cyrus-sasl-2.1.10-r2 (29 Jan 2003)
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.12.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.12.ebuild
new file mode 100644
index 000000000000..d8a26cb245d8
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.12.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.12.ebuild,v 1.1 2003/02/07 19:27:39 raker Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="~x86 ~ppc -sparc "
+IUSE="gdbm berkdb ldap mysql kerberos static ssl"
+
+RDEPEND=">=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/openssl-0.9.6d
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3.2.9 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ kerberos? ( virtual/krb5 )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-kerberos.patch
+}
+
+src_compile() {
+ libtoolize --copy --force
+ aclocal -I config -I cmulocal || die
+ autoheader || die
+ automake -a --foreign || die
+ autoconf || die
+ autoconf saslauthd/configure.in > saslauthd/configure || die
+ chmod +x saslauthd/configure || die
+
+ local myconf
+ myconf="--with-gnu-ld --enable-login --enable-ntlm"
+
+ use static && myconf="${myconf} --enable-static"
+
+ use ssl && myconf="${myconf} --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+
+ use ldap && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ if use berkdb; then
+ myconf="${myconf} --with-dblib=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --with-dblib=gdbm --with-gdbm=/usr"
+ else
+ myconf="${myconf} --with-dblib=berkeley"
+ fi
+
+ use kerberos && myconf="${myconf} --enable-gssapi" \
+ || myconf="${myconf} --disable-gssapi"
+ # Kerberos 4 support doesn't compile.. and i'm not sure why
+ # If you want to test/fix for me, emerge kth-krb
+ # and have at it. :) -raker 02/07/2003
+ #if [ "$ENABLE_KRB4" = "yes" ]; then
+ # myconf="${myconf} --enable-krb4=/usr/athena"
+ #else
+ myconf="${myconf} --disable-krb4"
+ #fi
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-plugindir=/usr/lib/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ ${myconf}
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ einstall || die "install problem"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ dodir /var/lib/sasl2
+ dodir /etc/sasl2
+ # generate an empty sasldb2 with correct permissions
+ LD_OLD=${LD_LIBRARY_PATH}
+ export LD_LIBRARY_PATH=${S}/lib/.libs
+ echo "gentoo" | ${D}usr/sbin/saslpasswd2 -f ${D}etc/sasl2/sasldb2 -p cyrus
+ ${D}usr/sbin/saslpasswd2 -f ${D}etc/sasl2/sasldb2 -d cyrus
+ export LD_LIBRARY_PATH=${LD_OLD}
+ chown root.mail ${D}etc/sasl2/sasldb2
+ chmod 0640 ${D}etc/sasl2/sasldb2
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd2.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.12-kerberos.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.12-kerberos.patch
new file mode 100644
index 000000000000..cfc9ad4ba174
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.12-kerberos.patch
@@ -0,0 +1,24 @@
+diff -urN cyrus-sasl-2.1.12/cmulocal/sasl2.m4 cyrus-sasl-2.1.12-modified/cmulocal/sasl2.m4
+--- cyrus-sasl-2.1.12/cmulocal/sasl2.m4 2003-02-03 11:09:08.000000000 -0600
++++ cyrus-sasl-2.1.12-modified/cmulocal/sasl2.m4 2003-02-06 03:27:59.000000000 -0600
+@@ -44,14 +44,15 @@
+
+ # Check a full link against the heimdal libraries. If this fails, assume
+ # MIT.
+- AC_CHECK_LIB(gssapi,gss_unwrap,gss_impl="heimdal",,$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} -lcom_err)
+-
++ if krb5-config --libs gssapi | grep -q -e -lroken ; then
++ AC_CHECK_LIB(gssapi,gss_unwrap,gss_impl="heimdal",,$GSSAPIBASE_LIBS `krb5-config --libs gssapi`)
++ fi
+ if test "$gss_impl" = "mit"; then
+- GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
++ GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS $(krb5-config --libs gssapi)"
+ GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_LIBS $gssapi_dir/libgssapi_krb5.a $gssapi_dir/libkrb5.a $gssapi_dir/libk5crypto.a $gssapi_dir/libcom_err.a"
+ elif test "$gss_impl" = "heimdal"; then
+- GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS -lgssapi -lkrb5 -lasn1 -lroken ${LIB_CRYPT} -lcom_err"
+- GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_STATIC_LIBS $gssapi_dir/libgssapi.a $gssapi_dir/libkrb5.a $gssapi_dir/libasn1.a $gssapi_dir/libroken.a $gssapi_dir/libcom_err.a ${LIB_CRYPT}"
++ GSSAPIBASE_LIBS="$GSSAPIBASE_LIBS $(krb5-config --libs gssapi)"
++ GSSAPIBASE_STATIC_LIBS="$GSSAPIBASE_STATIC_LIBS $(krb5-config --libs gssapi)"
+ else
+ gssapi="no"
+ AC_WARN(Disabling GSSAPI)
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.12 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.12
new file mode 100644
index 000000000000..bed7358c717a
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.12
@@ -0,0 +1 @@
+MD5 42cdb218959eb46c3ea70728c9da4385 cyrus-sasl-2.1.12.tar.gz 1343963