summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-15 13:04:59 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-15 13:04:59 +0000
commitdd1c20a513d60e8193b0bbc7915066771ceac340 (patch)
treecc4322e90016570cfdb782126e5b7eed57f3169b /dev-libs
parentRespect AR (bug 468174) (diff)
downloadgentoo-2-dd1c20a513d60e8193b0bbc7915066771ceac340.tar.gz
gentoo-2-dd1c20a513d60e8193b0bbc7915066771ceac340.tar.bz2
gentoo-2-dd1c20a513d60e8193b0bbc7915066771ceac340.zip
Version bump to 0.4.0, slotted libusb dependency, ebuild patch contributed by Martin Gysel (bearsh).
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdivecomputer/ChangeLog8
-rw-r--r--dev-libs/libdivecomputer/libdivecomputer-0.4.0.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-libs/libdivecomputer/ChangeLog b/dev-libs/libdivecomputer/ChangeLog
index db5a761f53ed..9db2afc32e89 100644
--- a/dev-libs/libdivecomputer/ChangeLog
+++ b/dev-libs/libdivecomputer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdivecomputer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.3 2013/03/28 18:46:35 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/ChangeLog,v 1.4 2013/05/15 13:04:59 tomwij Exp $
+
+*libdivecomputer-0.4.0 (15 May 2013)
+
+ 15 May 2013; Tom Wijsman <TomWij@gentoo.org> +libdivecomputer-0.4.0.ebuild:
+ Version bump to 0.4.0, slotted libusb dependency, ebuild patch contributed by
+ Martin Gysel (bearsh).
28 Mar 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Added proxy-maintainers to metadata.xml.
diff --git a/dev-libs/libdivecomputer/libdivecomputer-0.4.0.ebuild b/dev-libs/libdivecomputer/libdivecomputer-0.4.0.ebuild
new file mode 100644
index 000000000000..1dbd36d86b6e
--- /dev/null
+++ b/dev-libs/libdivecomputer/libdivecomputer-0.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivecomputer/libdivecomputer-0.4.0.ebuild,v 1.1 2013/05/15 13:04:59 tomwij Exp $
+
+EAPI="5"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://libdivecomputer.git.sourceforge.net/gitroot/libdivecomputer/libdivecomputer"
+ GIT_ECLASS="git-2"
+ AUTOTOOLIZE=yes
+fi
+
+inherit eutils autotools-utils ${GIT_ECLASS}
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.divesoftware.org/libdc/releases/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for communication with dive computers from various manufacturers."
+HOMEPAGE="http://www.divesoftware.org/libdc"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="usb examples +static-libs"
+
+RDEPEND="usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ if [[ -n ${AUTOTOOLIZE} ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ autotools-utils_src_configure
+
+ if use usb ; then
+ sed -i 's|#define HAVE_LIBUSB 1||' config.h || die "sed failed"
+ fi
+
+ if use examples ; then
+ sed -i 's|examples||' Makefile || die "sed failed"
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+}