summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:36:49 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:36:49 +0000
commitc3bca38eb29091655e161e72e5a1dfbc97559311 (patch)
tree5c0a2695316e1acd53d922349d62a393719824e0 /dev-libs
parentDrop obsoleted app-leechcraft/lc-sidebar from dependencies (diff)
downloadgentoo-2-c3bca38eb29091655e161e72e5a1dfbc97559311.tar.gz
gentoo-2-c3bca38eb29091655e161e72e5a1dfbc97559311.tar.bz2
gentoo-2-c3bca38eb29091655e161e72e5a1dfbc97559311.zip
Replace multilib_build_binaries with multilib_is_native_abi. The two are equivalent now, and the team has decided to use the old name as being less confusing.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpcre/ChangeLog8
-rw-r--r--dev-libs/libpcre/libpcre-8.34.ebuild8
-rw-r--r--dev-libs/libpcre/libpcre-8.35.ebuild8
3 files changed, 15 insertions, 9 deletions
diff --git a/dev-libs/libpcre/ChangeLog b/dev-libs/libpcre/ChangeLog
index 641056a9d306..913f88cb257c 100644
--- a/dev-libs/libpcre/ChangeLog
+++ b/dev-libs/libpcre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libpcre
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.230 2014/04/21 07:32:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/ChangeLog,v 1.231 2014/04/28 17:36:49 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org> libpcre-8.34.ebuild,
+ libpcre-8.35.ebuild:
+ Replace multilib_build_binaries with multilib_is_native_abi. The two are
+ equivalent now, and the team has decided to use the old name as being less
+ confusing.
21 Apr 2014; Michał Górny <mgorny@gentoo.org> libpcre-8.35.ebuild:
Use multilib_build_binaries consistently, and the new multilib_native_use*
diff --git a/dev-libs/libpcre/libpcre-8.34.ebuild b/dev-libs/libpcre/libpcre-8.34.ebuild
index b1db074e4d87..b5c089c9f7eb 100644
--- a/dev-libs/libpcre/libpcre-8.34.ebuild
+++ b/dev-libs/libpcre/libpcre-8.34.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.34.ebuild,v 1.3 2014/01/18 04:23:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.34.ebuild,v 1.4 2014/04/28 17:36:49 mgorny Exp $
EAPI="4"
@@ -57,8 +57,8 @@ multilib_src_configure() {
$(use_enable jit) $(use_enable jit pcregrep-jit) \
$(use_enable pcre16) \
$(use_enable pcre32) \
- $(multilib_build_binaries && use_enable libedit pcretest-libedit) \
- $(multilib_build_binaries && use_enable readline pcretest-libreadline) \
+ $(multilib_is_native_abi && use_enable libedit pcretest-libedit) \
+ $(multilib_is_native_abi && use_enable readline pcretest-libreadline) \
$(use_enable static-libs static) \
$(use_enable unicode utf) $(use_enable unicode unicode-properties) \
$(multilib_is_native_abi && use_enable zlib pcregrep-libz) \
@@ -75,7 +75,7 @@ multilib_src_compile() {
multilib_src_install() {
emake \
DESTDIR="${D}" \
- $(multilib_build_binaries || echo "bin_PROGRAMS=") \
+ $(multilib_is_native_abi || echo "bin_PROGRAMS=") \
$(multilib_is_native_abi || echo "dist_html_DATA=") \
install
multilib_is_native_abi && gen_usr_ldscript -a pcre
diff --git a/dev-libs/libpcre/libpcre-8.35.ebuild b/dev-libs/libpcre/libpcre-8.35.ebuild
index 402766cd7455..92741b7353bf 100644
--- a/dev-libs/libpcre/libpcre-8.35.ebuild
+++ b/dev-libs/libpcre/libpcre-8.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.35.ebuild,v 1.2 2014/04/21 07:32:16 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-8.35.ebuild,v 1.3 2014/04/28 17:36:49 mgorny Exp $
EAPI="4"
@@ -69,15 +69,15 @@ multilib_src_configure() {
}
multilib_src_compile() {
- emake V=1 $(multilib_build_binaries || echo "bin_PROGRAMS=")
+ emake V=1 $(multilib_is_native_abi || echo "bin_PROGRAMS=")
}
multilib_src_install() {
emake \
DESTDIR="${D}" \
- $(multilib_build_binaries || echo "bin_PROGRAMS= dist_html_DATA=") \
+ $(multilib_is_native_abi || echo "bin_PROGRAMS= dist_html_DATA=") \
install
- multilib_build_binaries && gen_usr_ldscript -a pcre
+ multilib_is_native_abi && gen_usr_ldscript -a pcre
}
multilib_src_install_all() {