summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 17:17:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-26 17:17:33 +0000
commita0d3510e57f42109eae8bc7b994a05d72ad9ce16 (patch)
tree9ef5f4fd9b4dcd44af63719f692a8b876c5497c0 /dev-libs
parentUpdate dependencies. (diff)
downloadgentoo-2-a0d3510e57f42109eae8bc7b994a05d72ad9ce16.tar.gz
gentoo-2-a0d3510e57f42109eae8bc7b994a05d72ad9ce16.tar.bz2
gentoo-2-a0d3510e57f42109eae8bc7b994a05d72ad9ce16.zip
Don't install .a files in Python site-packages directories.
(Portage version: 2.2.0_alpha25_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog6
-rw-r--r--dev-libs/libxml2/files/libxml2-2.7.8-disable_static_modules.patch12
-rw-r--r--dev-libs/libxml2/libxml2-2.7.8.ebuild8
3 files changed, 23 insertions, 3 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 3007efa4d6ea..7d23be34b995 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.303 2011/02/19 19:49:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.304 2011/02/26 17:17:33 arfrever Exp $
+
+ 26 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libxml2-2.7.8.ebuild, +files/libxml2-2.7.8-disable_static_modules.patch:
+ Don't install .a files in Python site-packages directories.
19 Feb 2011; Fabian Groffen <grobian@gentoo.org> libxml2-2.7.8.ebuild:
Drop --with-zlib argument for Prefix, it's no longer necessary
diff --git a/dev-libs/libxml2/files/libxml2-2.7.8-disable_static_modules.patch b/dev-libs/libxml2/files/libxml2-2.7.8-disable_static_modules.patch
new file mode 100644
index 000000000000..5f47e1d619cf
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.7.8-disable_static_modules.patch
@@ -0,0 +1,12 @@
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -21,7 +21,8 @@
+ libxml.py \
+ libxml2-python-api.xml
+
+-libxml2mod_la_LDFLAGS = @CYGWIN_EXTRA_LDFLAGS@ @WIN32_EXTRA_LDFLAGS@ -module -avoid-version
++libxml2mod_la_CPPFLAGS = -shared
++libxml2mod_la_LDFLAGS = @CYGWIN_EXTRA_LDFLAGS@ @WIN32_EXTRA_LDFLAGS@ -module -avoid-version -shared
+
+ if WITH_PYTHON
+ mylibs = \
diff --git a/dev-libs/libxml2/libxml2-2.7.8.ebuild b/dev-libs/libxml2/libxml2-2.7.8.ebuild
index d93a9f4a76e9..494206173ec0 100644
--- a/dev-libs/libxml2/libxml2-2.7.8.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.8.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.8.ebuild,v 1.8 2011/02/19 19:49:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.8.ebuild,v 1.9 2011/02/26 17:17:33 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="python? 2"
+PYTHON_USE_WITH="-build xml"
+PYTHON_USE_WITH_OPT="python"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
@@ -29,7 +32,6 @@ SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
RDEPEND="sys-libs/zlib
icu? ( dev-libs/icu )
- python? ( || ( <dev-lang/python-3[xml] ( <dev-lang/python-3 dev-python/pyxml ) ) )
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
@@ -74,6 +76,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}-xpath-freeing.patch"
epatch "${FILESDIR}/${P}-xpath-freeing2.patch"
+ epatch "${FILESDIR}/${P}-disable_static_modules.patch"
+
# Please do not remove, as else we get references to PORTAGE_TMPDIR
# in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
# We now need to run eautoreconf at the end to prevent maintainer mode.