summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2007-01-22 20:12:17 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2007-01-22 20:12:17 +0000
commit85762a534bbab95cae488c5005447e2ec10cf160 (patch)
tree0115c90419bbfc695c1798d1992672c1913eb34c /dev-libs
parentfixing sandbox violation (bug #163104) (diff)
downloadgentoo-2-85762a534bbab95cae488c5005447e2ec10cf160.tar.gz
gentoo-2-85762a534bbab95cae488c5005447e2ec10cf160.tar.bz2
gentoo-2-85762a534bbab95cae488c5005447e2ec10cf160.zip
New doc use flag for doxygen api documentation. Including a patch from Miloslav Trmac <mitr@redhat.com> from Fedora beecrypt rpm: fix b64encode() for data starting with NUL. Removed obsolete ebuild. Waiting mips stabilization for removing latest 3.x series ebuild.
(Portage version: 2.1.2-r2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/beecrypt/ChangeLog13
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild49
-rw-r--r--dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild79
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.1.2-base64.patch11
-rw-r--r--dev-libs/beecrypt/files/digest-beecrypt-3.1.0-r13
-rw-r--r--dev-libs/beecrypt/files/digest-beecrypt-4.1.2-r23
6 files changed, 105 insertions, 53 deletions
diff --git a/dev-libs/beecrypt/ChangeLog b/dev-libs/beecrypt/ChangeLog
index 843a6de06655..d72531b1de61 100644
--- a/dev-libs/beecrypt/ChangeLog
+++ b/dev-libs/beecrypt/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-libs/beecrypt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.51 2007/01/12 20:46:38 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.52 2007/01/22 20:12:17 sanchan Exp $
+
+*beecrypt-4.1.2-r2 (22 Jan 2007)
+
+ 22 Jan 2007; Sandro Bonazzola <sanchan@gentoo.org>
+ +files/beecrypt-4.1.2-base64.patch, -beecrypt-3.1.0-r1.ebuild,
+ +beecrypt-4.1.2-r2.ebuild:
+ New doc use flag for doxygen api documentation. Including a patch from
+ Miloslav Trmac <mitr@redhat.com> from Fedora beecrypt rpm: fix b64encode()
+ for data starting with NUL.
+ Removed obsolete ebuild. Waiting mips stabilization for removing latest 3.x
+ series ebuild.
12 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> beecrypt-4.1.2-r1.ebuild:
Remove WANT_AUTO*
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
deleted file mode 100644
index f0aa06e844f5..000000000000
--- a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.16 2006/06/15 19:55:07 sanchan Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Beecrypt is a general-purpose cryptography library."
-HOMEPAGE="http://sourceforge.net/projects/beecrypt"
-SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha amd64 ia64"
-IUSE="python"
-
-DEPEND="python? ( >=dev-lang/python-2.2 )
- !<app-arch/rpm-4.2.1"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- if use alpha; then
- # Prevent usage of lib64 on alpha where it isn't appropriate.
- # We only have one execution model, so all libraries install
- # in /usr/lib. Note: This patch modifies configure, not
- # configure.ac, because this package's Makefile is too smart
- # and screws up mpopt.s when configure.ac is modified.
- # (11 Nov 2003 agriffis)
- epatch ${FILESDIR}/beecrypt-3.1.0-alpha.patch
- fi
- # fix for python paths (#39282)
- epatch ${FILESDIR}/beecrypt-3.1.0-python2.3.patch
-}
-
-src_compile() {
- econf \
- `use_with python` \
- --enable-shared \
- --enable-static || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
- # Not needed
- rm -f ${D}/usr/lib/python*/site-packages/_bc.*a
- dodoc BUGS README BENCHMARKS NEWS
-}
diff --git a/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild b/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild
new file mode 100644
index 000000000000..061ca2256792
--- /dev/null
+++ b/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild,v 1.1 2007/01/22 20:12:17 sanchan Exp $
+
+inherit flag-o-matic eutils multilib autotools java-pkg-opt-2
+
+DESCRIPTION="general-purpose cryptography library"
+HOMEPAGE="http://sourceforge.net/projects/beecrypt"
+SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="java nocxx python threads doc"
+
+COMMONDEPEND="python? ( >=dev-lang/python-2.2 )
+ !<app-arch/rpm-4.2.1"
+
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set correct python libdir on multilib systems
+ sed -i -e 's:get_python_lib():get_python_lib(1,0):' \
+ configure.ac || die "sed failed"
+
+ # upstream patches from CVS
+ epatch "${FILESDIR}/${P}-python-Makefile-am.patch"
+ epatch "${FILESDIR}/${P}-python-debug-py-c.patch"
+ epatch "${FILESDIR}/${P}-build.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-threads.patch"
+ #Patch from Fedora rpm, Miloslav Trmac <mitr@redhat.com>
+ epatch "${FILESDIR}/${P}-base64.patch"
+ eautoreconf
+}
+
+src_compile() {
+ local myarch=$(get-flag march)
+ [[ -z ${myarch} ]] && myarch=${CHOST%%-*}
+ [[ ${myarch} == "athlon64" || ${myarch} == "k8" || ${myarch} == "opteron" || ${myarch} == "athlon-fx" ]] && \
+ [[ ${CHOST%%-*} != "x86_64" ]] && myarch=${CHOST%%-*}
+ econf \
+ $(use_enable threads) \
+ $(use_with !nocxx cplusplus) \
+ $(use_with java) \
+ $(use_with python) \
+ --with-arch=${myarch} \
+ --libdir=/usr/$(get_libdir) \
+ || die
+ emake || die "emake failed"
+ use doc && doxygen
+}
+
+src_test() {
+ export BEECRYPT_CONF_FILE=${T}/beecrypt-test.conf
+ echo provider.1=${S}/c++/provider/.libs/base.so > ${BEECRYPT_CONF_FILE}
+ make check || die "self test failed"
+ make bench || die "self benchmark test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ # Not needed
+ rm -f "${D}"/usr/$(get_libdir)/python*/site-packages/_bc.*a
+ dodoc BUGS README BENCHMARKS NEWS || die "dodoc failed"
+ use doc && dohtml -r docs/html/. || die "dohtml failed"
+}
diff --git a/dev-libs/beecrypt/files/beecrypt-4.1.2-base64.patch b/dev-libs/beecrypt/files/beecrypt-4.1.2-base64.patch
new file mode 100644
index 000000000000..c6c370bd0788
--- /dev/null
+++ b/dev-libs/beecrypt/files/beecrypt-4.1.2-base64.patch
@@ -0,0 +1,11 @@
+Fix b64encode() for data starting with NUL from Miloslav Trmac <mitr@redhat.com>
+--- beecrypt-4.1.2/base64.c.b64 2005-04-26 21:46:27.000000000 +0200
++++ beecrypt-4.1.2/base64.c 2005-04-26 21:47:48.000000000 +0200
+@@ -253,7 +253,6 @@
+ unsigned c;
+
+ if (s == NULL) return NULL;
+- if (*s == '\0') return calloc(1, sizeof(*t));
+
+ if (ns == 0) ns = strlen((const char*) s);
+ nt = ((ns + 2) / 3) * 4;
diff --git a/dev-libs/beecrypt/files/digest-beecrypt-3.1.0-r1 b/dev-libs/beecrypt/files/digest-beecrypt-3.1.0-r1
deleted file mode 100644
index 89b4d6802bff..000000000000
--- a/dev-libs/beecrypt/files/digest-beecrypt-3.1.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 1472cada46e2ab9f532f984de9740386 beecrypt-3.1.0.tar.gz 452555
-RMD160 da5f1ad11f8724ee75c2860252a881d1591ccb43 beecrypt-3.1.0.tar.gz 452555
-SHA256 50b574d330fecbc9faed81746a1abfcec903c264ae753ac64d4edf22c701519f beecrypt-3.1.0.tar.gz 452555
diff --git a/dev-libs/beecrypt/files/digest-beecrypt-4.1.2-r2 b/dev-libs/beecrypt/files/digest-beecrypt-4.1.2-r2
new file mode 100644
index 000000000000..776005bb16fb
--- /dev/null
+++ b/dev-libs/beecrypt/files/digest-beecrypt-4.1.2-r2
@@ -0,0 +1,3 @@
+MD5 820d26437843ab0a6a8a5151a73a657c beecrypt-4.1.2.tar.gz 774280
+RMD160 fe26e5429738450fa2ef00b37e9725eec29bda08 beecrypt-4.1.2.tar.gz 774280
+SHA256 f29eb246947677a9e7870521e3d576fd0d91a7072210a4404ed137e40cfc18fd beecrypt-4.1.2.tar.gz 774280