summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-04-27 13:47:49 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-04-27 13:47:49 +0000
commit7cb931640ac6e94b4d27cfbf0205680beeae5081 (patch)
tree4b5ab57ea83649246600211d3f8596b0b52c6cff /dev-libs
parentx86 stable wrt bug #315297 (diff)
downloadgentoo-2-7cb931640ac6e94b4d27cfbf0205680beeae5081.tar.gz
gentoo-2-7cb931640ac6e94b4d27cfbf0205680beeae5081.tar.bz2
gentoo-2-7cb931640ac6e94b4d27cfbf0205680beeae5081.zip
Version bump 0.3.2, fix bug 317389, restrict test, bug 315215
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libdbusmenu-qt/ChangeLog8
-rw-r--r--dev-libs/libdbusmenu-qt/files/libdbusmenu-qt-0.3.2-cmake.patch30
-rw-r--r--dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild5
-rw-r--r--dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.2-r1.ebuild32
4 files changed, 73 insertions, 2 deletions
diff --git a/dev-libs/libdbusmenu-qt/ChangeLog b/dev-libs/libdbusmenu-qt/ChangeLog
index 6180375c0bfd..7fe27b23ac31 100644
--- a/dev-libs/libdbusmenu-qt/ChangeLog
+++ b/dev-libs/libdbusmenu-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdbusmenu-qt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/ChangeLog,v 1.1 2010/03/31 16:31:18 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/ChangeLog,v 1.2 2010/04/27 13:47:48 reavertm Exp $
+
+*libdbusmenu-qt-0.3.2-r1 (27 Apr 2010)
+
+ 27 Apr 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ +libdbusmenu-qt-0.3.2-r1.ebuild, +files/libdbusmenu-qt-0.3.2-cmake.patch:
+ Version bump 0.3.2, fix bug 317389, restrict test, bug 315215
*libdbusmenu-qt-0.3.0 (31 Mar 2010)
diff --git a/dev-libs/libdbusmenu-qt/files/libdbusmenu-qt-0.3.2-cmake.patch b/dev-libs/libdbusmenu-qt/files/libdbusmenu-qt-0.3.2-cmake.patch
new file mode 100644
index 000000000000..e8e13c480bf4
--- /dev/null
+++ b/dev-libs/libdbusmenu-qt/files/libdbusmenu-qt-0.3.2-cmake.patch
@@ -0,0 +1,30 @@
+Only in .: build
+diff -ru ../libdbusmenu-qt-0.3.2/cmake/modules/FindQJSON.cmake ./cmake/modules/FindQJSON.cmake
+--- ../libdbusmenu-qt-0.3.2/cmake/modules/FindQJSON.cmake 2010-04-27 15:20:49.187784398 +0200
++++ ./cmake/modules/FindQJSON.cmake 2010-04-27 15:21:06.515858660 +0200
+@@ -17,14 +17,14 @@
+ # use pkg-config to get the values of QJSON_INCLUDE_DIRS
+ # and QJSON_LIBRARY_DIRS to add as hints to the find commands.
+ include (FindPkgConfig)
+- pkg_check_modules (QJSON QJson>=0.5)
++ pkg_check_modules (PC_QJSON QJson>=0.5)
+ endif (NOT WIN32)
+
+ find_library (QJSON_LIBRARIES
+ NAMES
+ qjson
+ PATHS
+- ${QJSON_LIBRARY_DIRS}
++ ${PC_QJSON_LIBRARY_DIRS}
+ ${LIB_INSTALL_DIR}
+ ${KDE4_LIB_DIR}
+ )
+@@ -35,7 +35,7 @@
+ PATH_SUFFIXES
+ qjson
+ PATHS
+- ${QJSON_INCLUDE_DIRS}
++ ${PC_QJSON_INCLUDE_DIRS}
+ ${INCLUDE_INSTALL_DIR}
+ ${KDE4_INCLUDE_DIR}
+ )
diff --git a/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild
index 18e4ee0d2a13..a0defa6fa6b6 100644
--- a/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild
+++ b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild,v 1.1 2010/03/31 16:31:18 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.0.ebuild,v 1.2 2010/04/27 13:47:48 reavertm Exp $
EAPI=2
@@ -16,6 +16,9 @@ KEYWORDS="~amd64 ~x86"
# Add "test" when the automatic/required dependency upon dev-libs/qjson is fixed!
IUSE=""
+# Bug #315215, require X server running
+RESTRICT="test"
+
# Change this to test?(qjson) when the automatic/required dep is fixed!
DEPEND="
dev-libs/qjson
diff --git a/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.2-r1.ebuild b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..77ff5a8a208f
--- /dev/null
+++ b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.3.2-r1.ebuild,v 1.1 2010/04/27 13:47:48 reavertm Exp $
+
+EAPI="3"
+
+inherit cmake-utils
+
+DESCRIPTION="A library providing Qt implementation of DBusMenu specification"
+HOMEPAGE="http://people.canonical.com/~agateau/dbusmenu/"
+SRC_URI="http://people.canonical.com/~agateau/dbusmenu/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug"
+
+# Bug #315215, require X server running
+RESTRICT="test"
+
+DEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-test:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.2-cmake.patch"
+)
+
+DOCS="NEWS README"