summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-02-07 19:13:59 +0000
committerJory Pratt <anarchy@gentoo.org>2010-02-07 19:13:59 +0000
commit7b870985e8e97f7d9ee34add602ca727d910961a (patch)
treee7f3723d0316156213b36703bd12e84002cee01b /dev-libs
parentMarked ~amd64 wrt bug #303099 (diff)
downloadgentoo-2-7b870985e8e97f7d9ee34add602ca727d910961a.tar.gz
gentoo-2-7b870985e8e97f7d9ee34add602ca727d910961a.tar.bz2
gentoo-2-7b870985e8e97f7d9ee34add602ca727d910961a.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nspr/ChangeLog7
-rw-r--r--dev-libs/nspr/nspr-4.8.3.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-libs/nspr/ChangeLog b/dev-libs/nspr/ChangeLog
index b36c30a06620..e35bc81f6236 100644
--- a/dev-libs/nspr/ChangeLog
+++ b/dev-libs/nspr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/nspr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.132 2010/01/27 02:08:23 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.133 2010/02/07 19:13:59 anarchy Exp $
+
+*nspr-4.8.3 (07 Feb 2010)
+
+ 07 Feb 2010; <anarchy@gentoo.org> +nspr-4.8.3.ebuild:
+ version bump
*nspr-4.8.2-r1 (27 Jan 2010)
diff --git a/dev-libs/nspr/nspr-4.8.3.ebuild b/dev-libs/nspr/nspr-4.8.3.ebuild
new file mode 100644
index 000000000000..faceec95bf10
--- /dev/null
+++ b/dev-libs/nspr/nspr-4.8.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.3.ebuild,v 1.1 2010/02/07 19:13:59 anarchy Exp $
+
+inherit eutils multilib toolchain-funcs versionator
+
+MIN_PV="$(get_version_component_range 2)"
+
+DESCRIPTION="Netscape Portable Runtime"
+HOMEPAGE="http://www.mozilla.org/projects/nspr/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 debug"
+
+DEPEND=">=dev-db/sqlite-3.5"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mkdir build inst
+ epatch "${FILESDIR}"/${PN}-4.8-config.patch
+ epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
+ epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
+ epatch "${FILESDIR}"/${PN}-4.7.0-prtime.patch
+ epatch "${FILESDIR}"/${PN}-4.8-pkgconfig-gentoo-1.patch
+
+ # Respect LDFLAGS
+ sed -i -e 's/\$(MKSHLIB) \$(OBJS)/\$(MKSHLIB) \$(LDFLAGS) \$(OBJS)/g' \
+ mozilla/nsprpub/config/rules.mk
+}
+
+src_compile() {
+ cd "${S}"/build
+
+ echo > "${T}"/test.c
+ $(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
+ case $(file "${T}"/test.o) in
+ *64-bit*) myconf="${myconf} --enable-64bit";;
+ *32-bit*) ;;
+ *) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
+ esac
+
+ myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr \
+ --enable-system-sqlite --with-mozilla --with-pthreads"
+
+ ECONF_SOURCE="../mozilla/nsprpub" econf \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ ${myconf} || die "econf failed"
+ make CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install () {
+ # Their build system is royally confusing, as usual
+ MINOR_VERSION=${MIN_PV} # Used for .so version
+ cd "${S}"/build
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd "${D}"/usr/$(get_libdir)/nspr
+ for file in *.so; do
+ mv ${file} ${file}.${MINOR_VERSION}
+ ln -s ${file}.${MINOR_VERSION} ${file}
+ done
+ # cope with libraries being in /usr/lib/nspr
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nspr" > "${D}/etc/env.d/08nspr"
+
+ # install nspr-config
+ dobin "${S}"/build/config/nspr-config
+
+ # create pkg-config file
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins "${S}"/build/config/nspr.pc
+
+ # Remove stupid files in /usr/bin
+ rm "${D}"/usr/bin/prerr.properties
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Please make sure you run revdep-rebuild after upgrade."
+ ewarn "This is *extremely* important to ensure your system nspr works properly."
+ ewarn
+}