summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-22 23:24:14 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-22 23:24:14 +0000
commit37ea67fafe2fa37ccb5ec5bf6aaec6c452bfa7b9 (patch)
tree9be5bd0ff1e9c7e0354e6d0c328c92fe4960d03b /dev-libs
parentFix -X, bug#210485 (diff)
downloadgentoo-2-37ea67fafe2fa37ccb5ec5bf6aaec6c452bfa7b9.tar.gz
gentoo-2-37ea67fafe2fa37ccb5ec5bf6aaec6c452bfa7b9.tar.bz2
gentoo-2-37ea67fafe2fa37ccb5ec5bf6aaec6c452bfa7b9.zip
Revision bump to ensure that -Wl,--as-needed get Flameeyes' fix.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xmlrpc-c/ChangeLog8
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.06.09-r1.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/xmlrpc-c/ChangeLog b/dev-libs/xmlrpc-c/ChangeLog
index 74578b94bb34..14bc73c506a4 100644
--- a/dev-libs/xmlrpc-c/ChangeLog
+++ b/dev-libs/xmlrpc-c/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xmlrpc-c
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.42 2008/02/21 14:03:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/ChangeLog,v 1.43 2008/02/22 23:24:14 ingmar Exp $
+
+*xmlrpc-c-1.06.09-r1 (22 Feb 2008)
+
+ 22 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +xmlrpc-c-1.06.09-r1.ebuild:
+ Revision bump to ensure that -Wl,--as-needed get Flameeyes' fix.
21 Feb 2008; Raúl Porcel <armin76@gentoo.org> xmlrpc-c-1.06.09.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09-r1.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09-r1.ebuild
new file mode 100644
index 000000000000..060c05f8cfb4
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xmlrpc-c/xmlrpc-c-1.06.09-r1.ebuild,v 1.1 2008/02/22 23:24:14 ingmar Exp $
+
+inherit eutils
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="curl libwww threads"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-libs/libxml2
+ libwww? ( net-libs/libwww
+ >=dev-libs/openssl-0.9.8g )
+ curl? ( net-misc/curl )"
+
+pkg_setup() {
+ if ! use curl && ! use libwww; then
+ ewarn "Neither CURL nor libwww support was selected"
+ ewarn "No client library will be be built"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.05-pic.patch
+ epatch "${FILESDIR}"/${PN}-1.06.02-threadupdatestatus.patch
+ epatch "${FILESDIR}"/${PN}-1.06.02-strsol.patch
+ epatch "${FILESDIR}"/${PN}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+
+ # Respect the user's CFLAGS/CXXFLAGS.
+ sed -i -e "/CFLAGS_COMMON/s:-g -O3$:${CFLAGS}:" Makefile.common
+ sed -i -e "/CXXFLAGS_COMMON/s:-g$:${CXXFLAGS}:" Makefile.common
+}
+
+src_compile() {
+ econf --disable-wininet-client --enable-libxml2-backend \
+ $(use_enable threads abyss-threads) \
+ $(use_enable curl curl-client) \
+ $(use_enable libwww libwww-client) || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "installation failed"
+
+ dodoc README doc/CREDITS doc/DEVELOPING doc/HISTORY doc/SECURITY doc/TESTING \
+ doc/TODO || die "installing docs failed"
+}