summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjoern Brauel <bjb@gentoo.org>2002-12-15 16:22:01 +0000
committerBjoern Brauel <bjb@gentoo.org>2002-12-15 16:22:01 +0000
commit17d57d2a122a63ffa890435365365efd11087d15 (patch)
treea989a0bd91555a40321b5fc18f1ae3413c321d88 /dev-libs
parentfix patch (diff)
downloadgentoo-2-17d57d2a122a63ffa890435365365efd11087d15.tar.gz
gentoo-2-17d57d2a122a63ffa890435365365efd11087d15.tar.bz2
gentoo-2-17d57d2a122a63ffa890435365365efd11087d15.zip
Initial ebuild of Compaq optimized math library for Alpha/Linux/GNU
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libcpml/ChangeLog8
-rw-r--r--dev-libs/libcpml/files/digest-libcpml-5.2.010
-rw-r--r--dev-libs/libcpml/libcpml-5.2.01.ebuild45
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libcpml/ChangeLog b/dev-libs/libcpml/ChangeLog
new file mode 100644
index 000000000000..f0e0fc9237c8
--- /dev/null
+++ b/dev-libs/libcpml/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/compaq-jdk
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/ChangeLog,v 1.1 2002/12/15 16:22:01 bjb Exp $
+
+*libcpml-5.2.01 (15 Dec 2002)
+ 15 Dec 2002; Bjoern Brauel <bjb@gentoo.org>
+ Initial ebuild
+
diff --git a/dev-libs/libcpml/files/digest-libcpml-5.2.01 b/dev-libs/libcpml/files/digest-libcpml-5.2.01
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-libs/libcpml/files/digest-libcpml-5.2.01
diff --git a/dev-libs/libcpml/libcpml-5.2.01.ebuild b/dev-libs/libcpml/libcpml-5.2.01.ebuild
new file mode 100644
index 000000000000..79d7b9f0e3af
--- /dev/null
+++ b/dev-libs/libcpml/libcpml-5.2.01.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcpml/libcpml-5.2.01.ebuild,v 1.1 2002/12/15 16:22:01 bjb Exp $
+
+At="cpml_ev5-5.2.0-1.alpha.rpm"
+S=${WORKDIR}/usr
+SRC_URI=""
+DESCRIPTION="Compaq Linux optimized (ev5) math library for Alpha/Linux/GNU"
+HOMEPAGE="http://h18000.www1.hp.com/math/index.html"
+DEPEND="virtual/glibc
+ app-arch/rpm2targz "
+RDEPEND="$DEPEND"
+LICENSE="compaq-sdla"
+SLOT="5.2.01"
+KEYWORDS="-x86 -ppc -sparc alpha"
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE}"
+ fi
+ rpm2targz ${DISTDIR}/${At}
+ tar zxf cpml_ev5-5.2.0-1.alpha.tar.gz
+ mv usr/doc/cpml-5.2.0/* usr
+
+}
+
+src_compile () {
+ cd ${WORKDIR}/usr/lib/compaq/cpml-5.2.0
+ ld -shared -o libcpml_ev5.so -soname libcpml.so -whole-archive libcpml_ev5.a -no-whole-archive -lots
+}
+
+src_install () {
+ dodir /usr/lib
+ cp -a lib/compaq/cpml-5.2.0/libcpml* ${D}/usr/lib
+
+ dodir /usr/include
+ cp lib/compaq/cpml-5.2.0/cpml.h ${D}/usr/include
+
+ dodoc README Release_Notes-5.2.0
+
+ cd ${D}/usr/lib/
+ ln -s libcpml_ev5.so libcpml.so
+ ln -s libcpml_ev5.a libcpml.a
+}
+