summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-11-01 15:43:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-11-01 15:43:55 +0000
commit0a6b67c84780146426be8306c2eaab7cbebb0bcc (patch)
tree67a233bb93da633a07819b8c5e3459f7bc811ac5 /dev-libs
parentUpdated ebuild to include link to te java archive download page. (diff)
downloadgentoo-2-0a6b67c84780146426be8306c2eaab7cbebb0bcc.tar.gz
gentoo-2-0a6b67c84780146426be8306c2eaab7cbebb0bcc.tar.bz2
gentoo-2-0a6b67c84780146426be8306c2eaab7cbebb0bcc.zip
Add live ebuild for testing
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cloog/ChangeLog7
-rw-r--r--dev-libs/cloog/cloog-9999.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/cloog/ChangeLog b/dev-libs/cloog/ChangeLog
index 95f42c4a63f5..de30c51dbcb2 100644
--- a/dev-libs/cloog/ChangeLog
+++ b/dev-libs/cloog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/cloog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/ChangeLog,v 1.21 2014/10/24 18:52:32 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/ChangeLog,v 1.22 2014/11/01 15:43:55 blueness Exp $
+
+*cloog-9999 (01 Nov 2014)
+
+ 01 Nov 2014; Anthony G. Basile <blueness@gentoo.org> +cloog-9999.ebuild:
+ Add live ebuild for testing
24 Oct 2014; Mikle Kolyada <zlogene@gentoo.org> cloog-0.18.1.ebuild:
amd64 stable wrt bug #516152
diff --git a/dev-libs/cloog/cloog-9999.ebuild b/dev-libs/cloog/cloog-9999.ebuild
new file mode 100644
index 000000000000..aaa7c54fa065
--- /dev/null
+++ b/dev-libs/cloog/cloog-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cloog/cloog-9999.ebuild,v 1.1 2014/11/01 15:43:55 blueness Exp $
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/cloog.git"
+ KEYWORDS=""
+ inherit autotools git-2
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+ SRC_URI="http://www.bastoul.net/cloog/pages/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="A loop generator for scanning polyhedra"
+HOMEPAGE="http://www.bastoul.net/cloog/index.php"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]
+ >=dev-libs/isl-0.12.2:0/10[${MULTILIB_USEDEP}]
+ !<dev-libs/cloog-ppl-0.15.10"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ ./get_submodules.sh
+ eautoreconf -i
+ else
+ # m4/ax_create_pkgconfig_info.m4 includes LDFLAGS
+ # sed to avoid eautoreconf
+ sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-gmp=system \
+ --with-isl=system \
+ --with-osl=no \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}