summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-04-18 21:04:21 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-04-18 21:04:21 +0000
commitf35e4333053790945d2a28fa1568e8df9bc70186 (patch)
treea92b9ba2f54ed63b99fd4f21ef136c4286f2e0ba /dev-libs/stfl
parentignored volumes clean up (diff)
downloadgentoo-2-f35e4333053790945d2a28fa1568e8df9bc70186.tar.gz
gentoo-2-f35e4333053790945d2a28fa1568e8df9bc70186.tar.bz2
gentoo-2-f35e4333053790945d2a28fa1568e8df9bc70186.zip
Specify toolchain compiler. Do not build perl or ruby bindings if respective USE flag is disabled, even if perl or ruby is installed on the system. Force -j1 to make, since the build system is weird and tends to break with multiple parallel jobs.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-libs/stfl')
-rw-r--r--dev-libs/stfl/ChangeLog8
-rw-r--r--dev-libs/stfl/stfl-0.8.ebuild17
2 files changed, 19 insertions, 6 deletions
diff --git a/dev-libs/stfl/ChangeLog b/dev-libs/stfl/ChangeLog
index ab622c743318..e6ab1662dffd 100644
--- a/dev-libs/stfl/ChangeLog
+++ b/dev-libs/stfl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/stfl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.1 2007/04/18 05:45:35 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/ChangeLog,v 1.2 2007/04/18 21:04:21 ticho Exp $
+
+ 18 Apr 2007; Andrej Kacian <ticho@gentoo.org> stfl-0.8.ebuild:
+ Specify toolchain compiler. Do not build perl or ruby bindings if respective
+ USE flag is disabled, even if perl or ruby is installed on the system. Force
+ -j1 to make, since the build system is weird and tends to break with
+ multiple parallel jobs.
*stfl-0.8 (17 Apr 2007)
diff --git a/dev-libs/stfl/stfl-0.8.ebuild b/dev-libs/stfl/stfl-0.8.ebuild
index f9a3402751dd..3a064831fd99 100644
--- a/dev-libs/stfl/stfl-0.8.ebuild
+++ b/dev-libs/stfl/stfl-0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.8.ebuild,v 1.1 2007/04/18 05:45:35 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.8.ebuild,v 1.2 2007/04/18 21:04:21 ticho Exp $
-inherit perl-module
+inherit perl-module toolchain-funcs
DESCRIPTION="A library which implements a curses-based widget set for text terminals"
HOMEPAGE="http://www.clifford.at/stfl/"
@@ -26,16 +26,23 @@ src_unpack() {
unpack "${A}"
cd "${S}"
sed -i \
- -e 's!-O0 -ggdb!!' \
- -e 's!^all:.*!all: libstfl.a!' \
+ -e "s!-O0 -ggdb!!" \
+ -e "s!^all:.*!all: libstfl.a!" \
Makefile
sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python2.4:" \
python/Makefile.snippet
+
+ if ! use perl; then
+ echo "FOUND_PERL5=0" >>Makefile.cfg
+ fi
+ if ! use ruby; then
+ echo "FOUND_RUBY=0" >>Makefile.cfg
+ fi
}
src_compile() {
- emake || die "make failed"
+ emake -j1 CC="$(tc-getCC)" || die "make failed"
}
src_install() {