summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2008-06-22 17:30:49 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2008-06-22 17:30:49 +0000
commitd6a9934db9a96a4d1a2f47fcf3c661b670670fc9 (patch)
tree9d08dc3f9086c36d3ce851a7f8aabecb54488468 /dev-libs/stfl/stfl-0.18.ebuild
parentUndoing previous change, as media-plugins/vdr-graphtft is unmasked again. (diff)
downloadgentoo-2-d6a9934db9a96a4d1a2f47fcf3c661b670670fc9.tar.gz
gentoo-2-d6a9934db9a96a4d1a2f47fcf3c661b670670fc9.tar.bz2
gentoo-2-d6a9934db9a96a4d1a2f47fcf3c661b670670fc9.zip
Fixed multilib bugs; keyworded ~amd64, bug #209304
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/stfl/stfl-0.18.ebuild')
-rw-r--r--dev-libs/stfl/stfl-0.18.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-libs/stfl/stfl-0.18.ebuild b/dev-libs/stfl/stfl-0.18.ebuild
index 2d485fd1f942..7b94b2c14f45 100644
--- a/dev-libs/stfl/stfl-0.18.ebuild
+++ b/dev-libs/stfl/stfl-0.18.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.18.ebuild,v 1.1 2007/12/27 12:47:51 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/stfl/stfl-0.18.ebuild,v 1.2 2008/06/22 17:30:49 gentoofan23 Exp $
-inherit perl-module toolchain-funcs eutils
+inherit perl-module toolchain-funcs eutils multilib
DESCRIPTION="A library which implements a curses-based widget set for text terminals"
HOMEPAGE="http://www.clifford.at/stfl/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.clifford.at/${PN}/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="examples perl ruby"
@@ -23,13 +23,14 @@ RDEPEND="sys-libs/ncurses
ruby? ( dev-lang/ruby )"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
sed -i \
-e "s!-Os -ggdb!!" \
-e "s!^all:.*!all: libstfl.a!" \
Makefile
+ epatch "${FILESDIR}/${P}-multilib.patch"
sed -i -e "s:/usr/lib/python2.4:${D}/usr/lib/python2.4:" \
python/Makefile.snippet
@@ -56,7 +57,7 @@ src_install() {
local exdir="/usr/share/doc/${PF}/examples"
dodir /usr/lib/python2.4/lib-dynload
- emake -j1 prefix="/usr" DESTDIR="${D}" install || die "make install failed"
+ emake -j1 prefix="/usr" DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "make install failed"
dodoc README