summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-10 05:55:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-10 05:55:01 +0000
commit64a203bede48d4b564e11852d05692ad2f2b9197 (patch)
tree349563f5bd9b9030762fb94fd2c52d2984bedf81 /dev-libs/quazip
parentAdd virtual/glu dependency for mesa-9, bug #434426, thanks to Andreas Sturmle... (diff)
downloadgentoo-2-64a203bede48d4b564e11852d05692ad2f2b9197.tar.gz
gentoo-2-64a203bede48d4b564e11852d05692ad2f2b9197.tar.bz2
gentoo-2-64a203bede48d4b564e11852d05692ad2f2b9197.zip
dev-libs/quazip: Version Bump; drop rpath hack
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/quazip')
-rw-r--r--dev-libs/quazip/ChangeLog8
-rw-r--r--dev-libs/quazip/files/rpath.cmake10
-rw-r--r--dev-libs/quazip/quazip-0.4.4.ebuild12
-rw-r--r--dev-libs/quazip/quazip-0.5.ebuild27
4 files changed, 35 insertions, 22 deletions
diff --git a/dev-libs/quazip/ChangeLog b/dev-libs/quazip/ChangeLog
index 0b7ed4116ab7..02b88ab70723 100644
--- a/dev-libs/quazip/ChangeLog
+++ b/dev-libs/quazip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/quazip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quazip/ChangeLog,v 1.18 2012/05/30 13:24:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quazip/ChangeLog,v 1.19 2012/09/10 05:55:01 jlec Exp $
+
+*quazip-0.5 (10 Sep 2012)
+
+ 10 Sep 2012; Justin Lecher <jlec@gentoo.org> quazip-0.4.4.ebuild,
+ +quazip-0.5.ebuild, -files/rpath.cmake:
+ Version Bump; drop rpath hack
30 May 2012; Justin Lecher <jlec@gentoo.org> quazip-0.4.4.ebuild,
+files/rpath.cmake:
diff --git a/dev-libs/quazip/files/rpath.cmake b/dev-libs/quazip/files/rpath.cmake
deleted file mode 100644
index b896c8789185..000000000000
--- a/dev-libs/quazip/files/rpath.cmake
+++ /dev/null
@@ -1,10 +0,0 @@
-# use, i.e. don't skip the full RPATH for the build tree
-SET(CMAKE_SKIP_BUILD_RPATH FALSE)
-
-# when building, don't use the install RPATH already
-# (but later on when installing)
-SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
-
-# add the automatically determined parts of the RPATH
-# which point to directories outside the build tree to the install RPATH
-SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
diff --git a/dev-libs/quazip/quazip-0.4.4.ebuild b/dev-libs/quazip/quazip-0.4.4.ebuild
index e2fe46d0228a..6a102a537ceb 100644
--- a/dev-libs/quazip/quazip-0.4.4.ebuild
+++ b/dev-libs/quazip/quazip-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quazip/quazip-0.4.4.ebuild,v 1.7 2012/05/30 13:24:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quazip/quazip-0.4.4.ebuild,v 1.8 2012/09/10 05:55:01 jlec Exp $
EAPI=4
@@ -25,13 +25,3 @@ S="${WORKDIR}"/${P}
DOCS="NEWS README.txt"
PATCHES=( "${FILESDIR}"/${P}-zlib.patch )
-
-src_prepare() {
- if use prefix; then
- cp "${FILESDIR}"/rpath.cmake .
- sed \
- -i '1iinclude(rpath.cmake)' \
- CMakeLists.txt || die
- fi
- base_src_prepare
-}
diff --git a/dev-libs/quazip/quazip-0.5.ebuild b/dev-libs/quazip/quazip-0.5.ebuild
new file mode 100644
index 000000000000..16a1e12c8e17
--- /dev/null
+++ b/dev-libs/quazip/quazip-0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quazip/quazip-0.5.ebuild,v 1.1 2012/09/10 05:55:01 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="A simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package"
+HOMEPAGE="http://quazip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ sys-libs/zlib
+ x11-libs/qt-core:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${P}
+
+DOCS="NEWS.txt README.txt"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.4-zlib.patch )