summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-11-30 22:50:23 +0000
committerMike Frysinger <vapier@gentoo.org>2013-11-30 22:50:23 +0000
commit0ffb0f93cdd390d64f75bf917fd575e282a5d910 (patch)
tree5f91fab8f6543a07e40d7eb05cd7994ebac42ec6 /dev-libs/protobuf
parentDepend on alsa-plugins with multilib fix. (diff)
downloadgentoo-2-0ffb0f93cdd390d64f75bf917fd575e282a5d910.tar.gz
gentoo-2-0ffb0f93cdd390d64f75bf917fd575e282a5d910.tar.bz2
gentoo-2-0ffb0f93cdd390d64f75bf917fd575e282a5d910.zip
Fix builds on x32.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/ChangeLog6
-rw-r--r--dev-libs/protobuf/files/protobuf-2.5.0-x32.patch15
-rw-r--r--dev-libs/protobuf/protobuf-2.5.0.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-libs/protobuf/ChangeLog b/dev-libs/protobuf/ChangeLog
index 2fed77e926ce..e16fa0fc7a33 100644
--- a/dev-libs/protobuf/ChangeLog
+++ b/dev-libs/protobuf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/protobuf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.53 2013/09/06 18:03:17 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/ChangeLog,v 1.54 2013/11/30 22:50:23 vapier Exp $
+
+ 30 Nov 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/protobuf-2.5.0-x32.patch, protobuf-2.5.0.ebuild:
+ Fix builds on x32.
06 Sep 2013; Tim Harder <radhermit@gentoo.org> protobuf-2.5.0.ebuild:
Add missing setuptools dep for python support (bug #479678 by hasufell).
diff --git a/dev-libs/protobuf/files/protobuf-2.5.0-x32.patch b/dev-libs/protobuf/files/protobuf-2.5.0-x32.patch
new file mode 100644
index 000000000000..5c8d47831807
--- /dev/null
+++ b/dev-libs/protobuf/files/protobuf-2.5.0-x32.patch
@@ -0,0 +1,15 @@
+fix from upstream for building w/x32
+
+https://code.google.com/p/protobuf/issues/detail?id=474
+
+--- src/google/protobuf/stubs/atomicops.h (revision 491)
++++ src/google/protobuf/stubs/atomicops.h (revision 492)
+@@ -66,7 +66,7 @@ typedef int32 Atomic32;
+ #ifdef GOOGLE_PROTOBUF_ARCH_64_BIT
+ // We need to be able to go between Atomic64 and AtomicWord implicitly. This
+ // means Atomic64 and AtomicWord should be the same type on 64-bit.
+-#if defined(GOOGLE_PROTOBUF_OS_NACL)
++#if defined(__ILP32__) || defined(GOOGLE_PROTOBUF_OS_NACL)
+ // NaCl's intptr_t is not actually 64-bits on 64-bit!
+ // http://code.google.com/p/nativeclient/issues/detail?id=1162
+ typedef int64 Atomic64;
diff --git a/dev-libs/protobuf/protobuf-2.5.0.ebuild b/dev-libs/protobuf/protobuf-2.5.0.ebuild
index 77d3f05c8428..7416b1de0bac 100644
--- a/dev-libs/protobuf/protobuf-2.5.0.ebuild
+++ b/dev-libs/protobuf/protobuf-2.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0.ebuild,v 1.5 2013/09/06 18:03:17 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.5.0.ebuild,v 1.6 2013/11/30 22:50:23 vapier Exp $
EAPI=5
JAVA_PKG_IUSE="source"
@@ -27,6 +27,7 @@ RDEPEND="${CDEPEND}
java? ( >=virtual/jre-1.5 )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-x32.patch
if [[ ${CHOST} != *-darwin* ]] ; then
# breaks Darwin, bug #472514
epatch "${FILESDIR}"/${PN}-2.3.0-asneeded-2.patch