summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-27 21:53:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-27 21:53:15 +0000
commit1610a22749235deafb1f233cd72ba1760a1fc793 (patch)
treea04f37e3a480ed4ef3605a427b618833fffe2c0a /dev-libs/nettle
parentamd64 stable - 270261 (diff)
downloadgentoo-2-1610a22749235deafb1f233cd72ba1760a1fc793.tar.gz
gentoo-2-1610a22749235deafb1f233cd72ba1760a1fc793.tar.bz2
gentoo-2-1610a22749235deafb1f233cd72ba1760a1fc793.zip
Version bump.
(Portage version: 13716-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/nettle')
-rw-r--r--dev-libs/nettle/ChangeLog10
-rw-r--r--dev-libs/nettle/nettle-2.0.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 99b61dc29711..d22325cbf319 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.21 2007/11/14 20:34:07 alonbl Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.22 2009/06/27 21:53:15 arfrever Exp $
+
+*nettle-2.0 (27 Jun 2009)
+
+ 27 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +nettle-2.0.ebuild:
+ Version bump.
14 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org>
-files/nettle-1.13-PIC.patch, -files/nettle-1.13-no-exec-stack.patch,
diff --git a/dev-libs/nettle/nettle-2.0.ebuild b/dev-libs/nettle/nettle-2.0.ebuild
new file mode 100644
index 000000000000..c6bd48ea4494
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.0.ebuild,v 1.1 2009/06/27 21:53:15 arfrever Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="cryptographic library that is designed to fit easily in any context"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="gmp ssl"
+
+DEPEND="gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ !<dev-libs/lsh-1.4.3-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS/s:-ggdb3::' \
+ configure.ac || die "sed configure.ac failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable gmp public-key) \
+ $(use_enable ssl openssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}