summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:37:12 +0000
committerFederico Ferri <mescalinum@gentoo.org>2008-11-13 06:37:12 +0000
commitd4fa9a8826d93c6e063d72be6e78342e91ded54b (patch)
treef0dca95f19ecb099ac0f86bc462b2c169289bb9c /dev-libs/libwbxml
parentRemove old. (diff)
downloadgentoo-2-d4fa9a8826d93c6e063d72be6e78342e91ded54b.tar.gz
gentoo-2-d4fa9a8826d93c6e063d72be6e78342e91ded54b.tar.bz2
gentoo-2-d4fa9a8826d93c6e063d72be6e78342e91ded54b.zip
getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed and tested.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/libwbxml')
-rw-r--r--dev-libs/libwbxml/ChangeLog9
-rw-r--r--dev-libs/libwbxml/libwbxml-0.9.2_p48.ebuild38
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/libwbxml/ChangeLog b/dev-libs/libwbxml/ChangeLog
index ccd4a874c097..de9c57ddbde7 100644
--- a/dev-libs/libwbxml/ChangeLog
+++ b/dev-libs/libwbxml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libwbxml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwbxml/ChangeLog,v 1.10 2008/07/28 13:40:20 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwbxml/ChangeLog,v 1.11 2008/11/13 06:37:12 mescalinum Exp $
+
+*libwbxml-0.9.2_p48 (13 Nov 2008)
+
+ 13 Nov 2008; Federico Ferri <mescalinum@gentoo.org>
+ +libwbxml-0.9.2_p48.ebuild:
+ getting synce-0.12 into tree. ebuild coming from synce overlay, reviewed
+ and tested.
28 Jul 2008; Michele Noberasco <s4t4n@gentoo.org> libwbxml-0.9.0.ebuild:
Wiped out oldest version. Closes bug #224909.
diff --git a/dev-libs/libwbxml/libwbxml-0.9.2_p48.ebuild b/dev-libs/libwbxml/libwbxml-0.9.2_p48.ebuild
new file mode 100644
index 000000000000..2beb980a48d4
--- /dev/null
+++ b/dev-libs/libwbxml/libwbxml-0.9.2_p48.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libwbxml/libwbxml-0.9.2_p48.ebuild,v 1.1 2008/11/13 06:37:12 mescalinum Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P="wbxml2-${PV%%_p*}+svn49synce"
+
+DESCRIPTION="Library and tools to parse, encode and handle WBXML documents."
+HOMEPAGE="http://libwbxml.aymerick.com/"
+SRC_URI="mirror://sourceforge/synce/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-libs/expat-1.95.8"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile()
+{
+ eautoreconf
+ econf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install()
+{
+ einstall || die "Installation failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README References THANKS TODO
+}
+