summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-02 22:38:59 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-02 22:38:59 +0000
commit7b404c3d388c5fb02d18361c375db6f2b4208b5a (patch)
tree0b704e1fbf878c36276c6df07ca7673a77acb326 /dev-libs/libsigc++
parentUpdate ebuild (diff)
downloadgentoo-2-7b404c3d388c5fb02d18361c375db6f2b4208b5a.tar.gz
gentoo-2-7b404c3d388c5fb02d18361c375db6f2b4208b5a.tar.bz2
gentoo-2-7b404c3d388c5fb02d18361c375db6f2b4208b5a.zip
Update ebuild, drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/ChangeLog7
-rw-r--r--dev-libs/libsigc++/files/libsigc++-2.3.2-missing-include.patch24
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.7.ebuild21
-rw-r--r--dev-libs/libsigc++/libsigc++-2.3.2-r1.ebuild55
4 files changed, 18 insertions, 89 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index b9aef1f648c8..ba33812b8ba3 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libsigc++
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.194 2014/10/02 12:02:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.195 2014/12/02 22:38:59 pacho Exp $
+
+ 02 Dec 2014; Pacho Ramos <pacho@gentoo.org>
+ -files/libsigc++-2.3.2-missing-include.patch, -libsigc++-2.3.2-r1.ebuild,
+ libsigc++-1.2.7.ebuild:
+ Update ebuild, drop old
*libsigc++-2.4.0 (02 Oct 2014)
diff --git a/dev-libs/libsigc++/files/libsigc++-2.3.2-missing-include.patch b/dev-libs/libsigc++/files/libsigc++-2.3.2-missing-include.patch
deleted file mode 100644
index 360694887e92..000000000000
--- a/dev-libs/libsigc++/files/libsigc++-2.3.2-missing-include.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From df361299c3f9a0922a683e5fa3869764932bb19a Mon Sep 17 00:00:00 2001
-From: Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
-Date: Fri, 8 Aug 2014 12:47:02 +0200
-Subject: Add an include in limit_reference.h
-
-* sigc++/macros/limit_reference.h.m4: limit_reference.h must include
-visit_each.h, with the primary definition of template struct visitor.
-https://mail.gnome.org/archives/libsigc-list/2014-August/msg00001.html
-
-diff --git a/sigc++/macros/limit_reference.h.m4 b/sigc++/macros/limit_reference.h.m4
-index 802446c..bb4b3b7 100644
---- a/sigc++/macros/limit_reference.h.m4
-+++ b/sigc++/macros/limit_reference.h.m4
-@@ -137,6 +137,7 @@ divert(0)
-
- _FIREWALL([LIMIT_REFERENCE])
-
-+#include <sigc++/visit_each.h>
- #include <sigc++/type_traits.h>
- #include <sigc++/trackable.h>
-
---
-cgit v0.10.1
-
diff --git a/dev-libs/libsigc++/libsigc++-1.2.7.ebuild b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
index b35b30345f93..8ae80095df4d 100644
--- a/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.7.ebuild,v 1.10 2013/06/29 12:18:33 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.7.ebuild,v 1.11 2014/12/02 22:38:59 pacho Exp $
-EAPI="3"
+EAPI=5
GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
inherit autotools gnome2 eutils
@@ -18,13 +19,8 @@ IUSE=""
DEPEND="sys-devel/m4"
RDEPEND=""
-pkg_setup() {
- DOCS="AUTHORS ChangeLog FEATURES IDEAS README NEWS TODO"
- G2CONF="${G2CONF} --enable-maintainer-mode --enable-threads"
-}
-
src_prepare() {
- gnome2_src_prepare
+ DOCS="AUTHORS ChangeLog FEATURES IDEAS README NEWS TODO"
# fixes bug #219041
sed -e 's:ACLOCAL_AMFLAGS = -I $(srcdir)/scripts:ACLOCAL_AMFLAGS = -I scripts:' \
@@ -37,4 +33,11 @@ src_prepare() {
epatch "${FILESDIR}/${P}-fix-install.patch"
eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-maintainer-mode \
+ --enable-threads
}
diff --git a/dev-libs/libsigc++/libsigc++-2.3.2-r1.ebuild b/dev-libs/libsigc++/libsigc++-2.3.2-r1.ebuild
deleted file mode 100644
index 3f241d98520b..000000000000
--- a/dev-libs/libsigc++/libsigc++-2.3.2-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.3.2-r1.ebuild,v 1.1 2014/09/07 12:41:18 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="no"
-
-inherit eutils gnome2 flag-o-matic
-
-DESCRIPTION="Typesafe callback system for standard C++"
-HOMEPAGE="http://libsigc.sourceforge.net/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs test"
-
-RDEPEND=""
-DEPEND="sys-devel/m4"
-# Needs mm-common for eautoreconf
-
-src_prepare() {
- # don't waste time building examples
- sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
- Makefile.am Makefile.in || die "sed examples failed"
-
- # don't waste time building tests unless USE=test
- if ! use test ; then
- sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
- Makefile.am Makefile.in || die "sed tests failed"
- fi
-
- # Add an include in limit_reference.h (from 'master'), bug #522166
- epatch "${FILESDIR}/${P}-missing-include.patch"
-
- gnome2_src_prepare
-}
-
-src_configure() {
- filter-flags -fno-exceptions
-
- gnome2_src_configure \
- $(use_enable doc documentation) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- gnome2_src_install
-
- if use doc ; then
- dohtml -r docs/reference/html/* docs/images/*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}