summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-05-22 02:23:21 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-05-22 02:23:21 +0000
commite05b443f322577e3b3db247e8f2e67dbd9c251a8 (patch)
treec55aae48cc82f03c9a9cae103d5b7c48773116bf /dev-libs/libol
parentupstream ftp checksum changes frequently so we mirror it now (diff)
downloadgentoo-2-e05b443f322577e3b3db247e8f2e67dbd9c251a8.tar.gz
gentoo-2-e05b443f322577e3b3db247e8f2e67dbd9c251a8.tar.bz2
gentoo-2-e05b443f322577e3b3db247e8f2e67dbd9c251a8.zip
ebuild cleanup and devel version
Diffstat (limited to 'dev-libs/libol')
-rw-r--r--dev-libs/libol/ChangeLog18
-rw-r--r--dev-libs/libol/files/digest-libol-0.3.21
-rw-r--r--dev-libs/libol/libol-0.2.23.ebuild20
-rw-r--r--dev-libs/libol/libol-0.3.2.ebuild25
4 files changed, 45 insertions, 19 deletions
diff --git a/dev-libs/libol/ChangeLog b/dev-libs/libol/ChangeLog
index 970976aca01b..2d7e9c616ad6 100644
--- a/dev-libs/libol/ChangeLog
+++ b/dev-libs/libol/ChangeLog
@@ -1,13 +1,17 @@
# ChangeLog for dev-libs/libol
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libol/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libol/ChangeLog,v 1.2 2002/05/22 02:23:21 blocke Exp $
+
+*libol-0.3.2 (21 May 2002)
+
+ 21 May 2002; Bruce A. Locke <blocke@shivan.org> libol-0.3.2.ebuild:
+
+ New ebuild for devel branch version... masked out for now.
*libol-0.2.23 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ 21 May 2002; Bruce A. Locke <blocke@shivan.org> libol-0.2.23.ebuild:
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ Modernized.
+
+
diff --git a/dev-libs/libol/files/digest-libol-0.3.2 b/dev-libs/libol/files/digest-libol-0.3.2
new file mode 100644
index 000000000000..394506ed5bb1
--- /dev/null
+++ b/dev-libs/libol/files/digest-libol-0.3.2
@@ -0,0 +1 @@
+MD5 9ee034c0b663a7817721f2711c36bff6 libol-0.3.2.tar.gz 155317
diff --git a/dev-libs/libol/libol-0.2.23.ebuild b/dev-libs/libol/libol-0.2.23.ebuild
index 24f0562c1eef..5fa4d10b454e 100644
--- a/dev-libs/libol/libol-0.2.23.ebuild
+++ b/dev-libs/libol/libol-0.2.23.ebuild
@@ -1,29 +1,25 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Bruce Locke <blocke@shivan.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libol/libol-0.2.23.ebuild,v 1.5 2001/11/10 12:05:20 hallski Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libol/libol-0.2.23.ebuild,v 1.6 2002/05/22 02:23:21 blocke Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Support library for syslog-ng"
SRC_URI="http://www.balabit.hu/downloads/libol/0.2/${P}.tar.gz"
HOMEPAGE="http://www.balabit.hu/en/products/syslog-ng/"
+SLOT="0"
+LICENSE="GPL"
-#DEPEND=">="
+DEPEND=""
src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --enable-shared \
- --enable-static \
- --disable-libtool-lock
- assert
- make CFLAGS="${CFLAGS}" ${MAKEOPTS} prefix=${D}/usr all || die
+ econf --enable-shared --enable-static --disable-libtool-lock || die
+ emake CFLAGS="${CFLAGS}" all || die
}
src_install() {
- make prefix=${D}/usr install || die
+ einstall || die
dodoc ChangeLog
}
diff --git a/dev-libs/libol/libol-0.3.2.ebuild b/dev-libs/libol/libol-0.3.2.ebuild
new file mode 100644
index 000000000000..e6f571c6a035
--- /dev/null
+++ b/dev-libs/libol/libol-0.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libol/libol-0.3.2.ebuild,v 1.1 2002/05/22 02:23:21 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Support library for syslog-ng"
+SRC_URI="http://www.balabit.hu/downloads/libol/0.3/${P}.tar.gz"
+HOMEPAGE="http://www.balabit.hu/en/products/syslog-ng/"
+SLOT="0"
+LICENSE="GPL"
+
+DEPEND=""
+
+src_compile() {
+
+ econf --enable-shared --enable-static --disable-libtool-lock || die
+ emake CFLAGS="${CFLAGS}" all || die
+}
+
+src_install() {
+
+ einstall || die
+ dodoc ChangeLog
+}