summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 17:43:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 17:43:34 +0000
commit2552734460a4bc263ceb3d00add8a82978ebf69c (patch)
treea12bda881785475a87b6d143bb13f003bd265815 /dev-libs/libindicate
parentPunt masked dv packages. (diff)
downloadgentoo-2-2552734460a4bc263ceb3d00add8a82978ebf69c.tar.gz
gentoo-2-2552734460a4bc263ceb3d00add8a82978ebf69c.tar.bz2
gentoo-2-2552734460a4bc263ceb3d00add8a82978ebf69c.zip
Version bump, moved from kde overlay, thanks to Dennis Schridde. Reference launchpad bugs for the patches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libindicate')
-rw-r--r--dev-libs/libindicate/ChangeLog11
-rw-r--r--dev-libs/libindicate/files/libindicate-0.3.6-no-gobject-introspection.patch10
-rw-r--r--dev-libs/libindicate/files/libindicate-0.3.6-optional-gtk-support.patch181
-rw-r--r--dev-libs/libindicate/libindicate-0.3.6.ebuild59
4 files changed, 260 insertions, 1 deletions
diff --git a/dev-libs/libindicate/ChangeLog b/dev-libs/libindicate/ChangeLog
index 88636c39d852..97fcdd26115e 100644
--- a/dev-libs/libindicate/ChangeLog
+++ b/dev-libs/libindicate/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/libindicate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.6 2010/02/16 17:15:10 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.7 2010/03/31 17:43:34 tampakrap Exp $
+
+*libindicate-0.3.6 (31 Mar 2010)
+
+ 31 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +libindicate-0.3.6.ebuild,
+ +files/libindicate-0.3.6-no-gobject-introspection.patch,
+ +files/libindicate-0.3.6-optional-gtk-support.patch:
+ Version bump, moved from kde overlay, thanks to Dennis Schridde.Reference
+ launchpad bugs for the patches
16 Feb 2010; Joseph Jezak <josejx@gentoo.org> libindicate-0.2.3-r1.ebuild:
Marked ~ppc/~ppc64 for bug #304365.
diff --git a/dev-libs/libindicate/files/libindicate-0.3.6-no-gobject-introspection.patch b/dev-libs/libindicate/files/libindicate-0.3.6-no-gobject-introspection.patch
new file mode 100644
index 000000000000..718b70b08b54
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.3.6-no-gobject-introspection.patch
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2010-03-31 12:42:16.497596552 +0200
++++ configure.ac 2010-03-31 12:42:47.001595062 +0200
+@@ -87,6 +87,6 @@
+ ###########################
+
+-GOBJECT_INTROSPECTION_CHECK([0.6.3])
++AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+
+ ###########################
+ # GTK Doc
diff --git a/dev-libs/libindicate/files/libindicate-0.3.6-optional-gtk-support.patch b/dev-libs/libindicate/files/libindicate-0.3.6-optional-gtk-support.patch
new file mode 100644
index 000000000000..38e870a7704a
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.3.6-optional-gtk-support.patch
@@ -0,0 +1,181 @@
+Date: Mon, 23 Nov 2009 23:14:01 +0100
+Subject: Make gtk support optional, Fix some QA
+
+---
+ Makefile.am | 17 +++++++----
+ configure.ac | 23 +++++++++++----
+ examples/Makefile.am | 64 ++++++++++++++++++++++---------------------
+ libindicate-gtk/Makefile.am | 2 +-
+ tests/Makefile.am | 2 +-
+ 5 files changed, 63 insertions(+), 45 deletions(-)
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,10 +1,15 @@
++SUBDIRS = libindicate
+
+-SUBDIRS = \
+- libindicate \
+- libindicate-gtk \
+- examples \
+- tests \
+- docs
++if HAVE_LIBINDICATEGTK
++SUBDIRS += libindicate-gtk
++endif
++
++SUBDIRS += \
++ examples \
++ tests
++if INSTALL_DOC
++SUBDIRS += docs
++endif
+
+ EXTRA_DIST = \
+ COPYING.LGPL.2.1 \
+--- a/configure.ac
++++ b/configure.ac
+@@ -66,12 +66,19 @@ AC_SUBST(LIBINDICATE_LIBS)
+
+ GDK_PIXBUF_REQUIRED_VERSION=2.12
+
++AC_ARG_ENABLE([gtk],
++ AC_HELP_STRING([--disable-gtk], [Disable libindicate-gtk library]),
++ [enable_gtk=$enableval], enable_gtk=auto)
++
++if test "x$enable_gtk" != "xno"; then
+ PKG_CHECK_MODULES(LIBINDICATEGTK, glib-2.0 >= $GLIB_REQUIRED_VERSION
+ gio-2.0 >= $GIO_REQUIRED_VERSION
+ gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ dbusmenu-glib >= $DBUSMENU_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
++fi
++AM_CONDITIONAL([HAVE_LIBINDICATEGTK], [test "x$enable_gtk" != "xno"])
+ AC_SUBST(LIBINDICATEGTK_CFLAGS)
+ AC_SUBST(LIBINDICATEGTK_LIBS)
+
+@@ -85,8 +92,12 @@ AM_CONDITIONAL(USE_GIR, test "x$gir_ok" = "xyes")
+ # GTK Doc
+ ###########################
+
++AC_ARG_ENABLE([doc],
++ AC_HELP_STRING([--disable-doc], [Do not install API doc]),
++ [enable_doc=$enableval], [enable_doc=auto])
++AM_CONDITIONAL([INSTALL_DOC], [test "x$enable_doc" != "xno"])
+ GTK_DOC_CHECK([1.4])
+-GNOME_DOC_INIT
++#GNOME_DOC_INIT
+ GNOME_COMPILE_WARNINGS
+
+ ##############################
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -1,35 +1,12 @@
+
+-libexec_PROGRAMS = \
++EXTRA_PROGRAMS = \
+ indicate-and-crash \
+ indicate-alot \
+- listen-and-print \
+- im-client \
+ show-hide-server
+-
+-indicate_and_crash_SOURCES = \
+- indicate-and-crash.c
+-
+-indicate_and_crash_CFLAGS = \
+- -I $(srcdir)/.. \
+- -Wall -Werror \
+- $(LIBINDICATE_CFLAGS)
+-
+-indicate_and_crash_LDADD = \
+- ../libindicate/libindicate.la \
+- $(LIBINDICATE_LIBS)
+-
+-indicate_alot_SOURCES = \
+- indicate-alot.c
+-
+-indicate_alot_CFLAGS = \
+- -I $(srcdir)/.. \
+- -Wall -Werror \
+- $(LIBINDICATE_CFLAGS)
+-
+-indicate_alot_LDADD = \
+- ../libindicate/libindicate.la \
+- $(LIBINDICATE_LIBS)
+-
++if HAVE_LIBINDICATEGTK
++EXTRA_PROGRAMS += \
++ listen-and-print \
++ im-client
+ listen_and_print_SOURCES = \
+ listen-and-print.c
+
+@@ -40,8 +16,8 @@ listen_and_print_CFLAGS = \
+ $(LIBINDICATEGTK_CFLAGS)
+
+ listen_and_print_LDADD = \
+- ../libindicate/libindicate.la \
+- ../libindicate-gtk/libindicate-gtk.la \
++ $(top_srcdir)/libindicate/libindicate.la \
++ $(top_srcdir)/libindicate-gtk/libindicate-gtk.la \
+ $(LIBINDICATE_LIBS) \
+ $(LIBINDICATEGTK_LIBS)
+
+@@ -55,10 +30,33 @@ im_client_CFLAGS = \
+ $(LIBINDICATEGTK_CFLAGS)
+
+ im_client_LDADD = \
+- ../libindicate/libindicate.la \
+- ../libindicate-gtk/libindicate-gtk.la \
++ $(top_srcdir)/libindicate/libindicate.la \
++ $(top_srcdir)/libindicate-gtk/libindicate-gtk.la \
+ $(LIBINDICATE_LIBS) \
+ $(LIBINDICATEGTK_LIBS)
++endif
++
++indicate_and_crash_SOURCES = \
++ indicate-and-crash.c
++
++indicate_and_crash_CFLAGS = \
++ -I $(srcdir)/.. \
++ $(LIBINDICATE_CFLAGS)
++
++indicate_and_crash_LDADD = \
++ $(top_srcdir)/libindicate/libindicate.la \
++ $(LIBINDICATE_LIBS)
++
++indicate_alot_SOURCES = \
++ indicate-alot.c
++
++indicate_alot_CFLAGS = \
++ -I $(srcdir)/.. \
++ $(LIBINDICATE_CFLAGS)
++
++indicate_alot_LDADD = \
++ $(top_srcdir)/libindicate/libindicate.la \
++ $(LIBINDICATE_LIBS)
+
+ show_hide_server_SOURCES = \
+ show-hide-server.c
+@@ -69,7 +66,7 @@ show_hide_server_CFLAGS = \
+ $(LIBINDICATE_CFLAGS)
+
+ show_hide_server_LDADD = \
+- ../libindicate/libindicate.la \
++ $(top_srcdir)/libindicate/libindicate.la \
+ $(LIBINDICATE_LIBS)
+
+ examplesdir = $(docdir)/examples/
+--- a/libindicate-gtk/Makefile.am
++++ b/libindicate-gtk/Makefile.am
+@@ -33,7 +33,7 @@ libindicate_gtk_la_CFLAGS = \
+ $(LIBINDICATEGTK_CFLAGS)
+
+ libindicate_gtk_la_LIBADD = \
+- ../libindicate/libindicate.la \
++ $(top_srcdir)/libindicate/libindicate.la \
+ $(LIBINDICATEGTK_LIBS)
+
+ pkgconfig_DATA = indicate-gtk.pc
diff --git a/dev-libs/libindicate/libindicate-0.3.6.ebuild b/dev-libs/libindicate/libindicate-0.3.6.ebuild
new file mode 100644
index 000000000000..0ed83a425046
--- /dev/null
+++ b/dev-libs/libindicate/libindicate-0.3.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-0.3.6.ebuild,v 1.1 2010/03/31 17:43:34 tampakrap Exp $
+
+EAPI=2
+
+inherit autotools eutils versionator
+
+DESCRIPTION="Library to raise flags on DBus for other components of the desktop to pick up and visualize"
+HOMEPAGE="https://launchpad.net/libindicate/"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk doc"
+# They put their mother in the tarball ? ^^
+RESTRICT="test"
+
+# For the dependency on dev-libs/libdbusmenu see launchpad-bug #552667
+RDEPEND="dev-libs/glib:2
+ dev-libs/dbus-glib
+ dev-libs/libdbusmenu
+ dev-libs/libxml2:2
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Make libindicator-gtk library optional, launchpad-bug #431311
+ epatch "${FILESDIR}/${P}-optional-gtk-support.patch"
+ # Fixup undeclared HAVE_INTROSPECTION, launchpad-bug #552537
+ epatch "${FILESDIR}/${P}-no-gobject-introspection.patch"
+ # Drop -Werror in a release
+ sed -e 's:-Werror::g' -i libindicate/Makefile.am libindicate-gtk/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ local my_conf
+
+ # gobject-instrospection is a nightmare in this package, it's fixable for libindicate
+ # and not for libindicate-gtk, disable it until its fixed on upstream
+ my_conf="--disable-dependency-tracking
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable gtk)
+ $(use_enable doc)"
+ econf $my_conf
+}
+
+src_test() {
+ emake check || die "testsuite failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS || die "dodoc failed"
+}