summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-27 06:30:41 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-27 06:30:41 +0000
commit8b1b68be320c6e702ae8148203497a8cf0fe9818 (patch)
tree5a7caf7c970547e4e2734be1e3cfe53f248b134d /dev-libs/libiconv
parentmask out more unkeyworded packages (diff)
downloadgentoo-2-8b1b68be320c6e702ae8148203497a8cf0fe9818.tar.gz
gentoo-2-8b1b68be320c6e702ae8148203497a8cf0fe9818.tar.bz2
gentoo-2-8b1b68be320c6e702ae8148203497a8cf0fe9818.zip
Fix build w/newer glibc, and simplify install phase.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-libs/libiconv')
-rw-r--r--dev-libs/libiconv/ChangeLog8
-rw-r--r--dev-libs/libiconv/files/libiconv-1.14-no-gets.patch22
-rw-r--r--dev-libs/libiconv/libiconv-1.14-r1.ebuild16
3 files changed, 35 insertions, 11 deletions
diff --git a/dev-libs/libiconv/ChangeLog b/dev-libs/libiconv/ChangeLog
index f23c2d18a2a0..7a469ee055b9 100644
--- a/dev-libs/libiconv/ChangeLog
+++ b/dev-libs/libiconv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libiconv
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.45 2013/12/24 12:43:52 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.46 2014/03/27 06:30:41 vapier Exp $
+
+ 27 Mar 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/libiconv-1.14-no-gets.patch, libiconv-1.14-r1.ebuild:
+ Fix build w/newer glibc, and simplify install phase.
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> libiconv-1.14-r1.ebuild:
Stable for x86, wrt bug #492042
diff --git a/dev-libs/libiconv/files/libiconv-1.14-no-gets.patch b/dev-libs/libiconv/files/libiconv-1.14-no-gets.patch
new file mode 100644
index 000000000000..db767ac1dd81
--- /dev/null
+++ b/dev-libs/libiconv/files/libiconv-1.14-no-gets.patch
@@ -0,0 +1,22 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/srclib/stdio.in.h
++++ b/srclib/stdio.in.h
+@@ -695,7 +695,6 @@ _GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
+
diff --git a/dev-libs/libiconv/libiconv-1.14-r1.ebuild b/dev-libs/libiconv/libiconv-1.14-r1.ebuild
index ac0c73dcc69d..e807ce5e53e4 100644
--- a/dev-libs/libiconv/libiconv-1.14-r1.ebuild
+++ b/dev-libs/libiconv/libiconv-1.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.14-r1.ebuild,v 1.4 2013/12/24 12:43:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.14-r1.ebuild,v 1.5 2014/03/27 06:30:41 vapier Exp $
EAPI="4"
@@ -20,25 +20,23 @@ DEPEND="!sys-libs/glibc
RDEPEND="${DEPEND}"
src_prepare() {
- # Make sure that libtool support is updated to link "the linux way"
- # on FreeBSD.
+ epatch "${FILESDIR}"/${P}-no-gets.patch
elibtoolize
}
multilib_src_configure() {
# Disable NLS support because that creates a circular dependency
# between libiconv and gettext
- ECONF_SOURCE="${S}" econf \
+ ECONF_SOURCE="${S}" \
+ econf \
--docdir="\$(datarootdir)/doc/${PF}/html" \
--disable-nls \
--enable-shared \
$(use_enable static-libs static)
}
-multilib_src_install() {
- default
-
+multilib_src_install_all() {
# Install in /lib as utils installed in /lib like gnutar
# can depend on this
- [ "${ABI}" = "${DEFAULT_ABI}" ] && gen_usr_ldscript -a iconv charset
+ gen_usr_ldscript -a iconv charset
}