summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 17:47:47 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 17:47:47 +0000
commitf930599a6168eb595e006222adaf40232807908c (patch)
treeb4adb5be9103e85c29856cc9ff1b67cdae5288e1 /dev-libs/libgweather
parentAdd new version for Gnome 2.30 (diff)
downloadgentoo-2-f930599a6168eb595e006222adaf40232807908c.tar.gz
gentoo-2-f930599a6168eb595e006222adaf40232807908c.tar.bz2
gentoo-2-f930599a6168eb595e006222adaf40232807908c.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog7
-rw-r--r--dev-libs/libgweather/libgweather-2.30.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 0449a93007c4..d1a07aab73a7 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.52 2010/06/04 20:10:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.53 2010/06/13 17:47:47 pacho Exp $
+
+*libgweather-2.30.0 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +libgweather-2.30.0.ebuild:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> libgweather-2.28.0.ebuild:
x86 stable, bug #314899
diff --git a/dev-libs/libgweather/libgweather-2.30.0.ebuild b/dev-libs/libgweather/libgweather-2.30.0.ebuild
new file mode 100644
index 000000000000..31b76dff9944
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-2.30.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.0.ebuild,v 1.1 2010/06/13 17:47:47 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="python doc"
+
+RDEPEND=">=x11-libs/gtk+-2.11
+ >=dev-libs/glib-2.13
+ >=gnome-base/gconf-2.8
+ >=net-libs/libsoup-2.25.1:2.4[gnome]
+ >=dev-libs/libxml2-2.6.0
+ python? (
+ >=dev-python/pygobject-2
+ >=dev-python/pygtk-2 )
+ !<gnome-base/gnome-applets-2.22.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.3
+ >=dev-util/pkgconfig-0.19
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-all-translations-in-one-xml
+ --disable-static
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: tarball generated with broken gtk-doc, revisit me.
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+ # Fix building -python, Gnome bug #596660.
+ epatch "${FILESDIR}/${PN}-fix-automagic-python-support.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}