summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-09 21:24:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-04-09 21:24:00 +0000
commitaec675d7003dc1ef35a4152f24ccb5a4a965de3e (patch)
treecbe3cc516f5ae7dc553d73d72d968f44510f936d /dev-libs/libgpg-error/libgpg-error-1.7.ebuild
parentAdd missing gtk-doc-am DEPEND, bug #265514. (diff)
downloadgentoo-2-aec675d7003dc1ef35a4152f24ccb5a4a965de3e.tar.gz
gentoo-2-aec675d7003dc1ef35a4152f24ccb5a4a965de3e.tar.bz2
gentoo-2-aec675d7003dc1ef35a4152f24ccb5a4a965de3e.zip
Version bump.
(Portage version: 13308-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgpg-error/libgpg-error-1.7.ebuild')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.7.ebuild b/dev-libs/libgpg-error/libgpg-error-1.7.ebuild
new file mode 100644
index 000000000000..215c01c61b23
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.7.ebuild,v 1.1 2009/04/09 21:24:00 arfrever Exp $
+
+inherit libtool
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # for BSD?
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable nls)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}