summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-02-06 19:12:39 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-02-06 19:12:39 +0000
commitae33cb9c1cc720d8843fa977a0a92786fa7d2a73 (patch)
tree3f526b18160bda66781bbbd7b119a62b69358aec /dev-libs/libdbusmenu-qt
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-ae33cb9c1cc720d8843fa977a0a92786fa7d2a73.tar.gz
gentoo-2-ae33cb9c1cc720d8843fa977a0a92786fa7d2a73.tar.bz2
gentoo-2-ae33cb9c1cc720d8843fa977a0a92786fa7d2a73.zip
Version bump, ebuild by Dennis Schridde
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdbusmenu-qt')
-rw-r--r--dev-libs/libdbusmenu-qt/ChangeLog8
-rw-r--r--dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.7.0.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/libdbusmenu-qt/ChangeLog b/dev-libs/libdbusmenu-qt/ChangeLog
index 604a75a8ed62..c049b959a9ad 100644
--- a/dev-libs/libdbusmenu-qt/ChangeLog
+++ b/dev-libs/libdbusmenu-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdbusmenu-qt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/ChangeLog,v 1.14 2011/01/14 22:13:12 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/ChangeLog,v 1.15 2011/02/06 19:12:39 tampakrap Exp $
+
+*libdbusmenu-qt-0.7.0 (06 Feb 2011)
+
+ 06 Feb 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +libdbusmenu-qt-0.7.0.ebuild:
+ Version bump, ebuild by Dennis Schridde
14 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org>
libdbusmenu-qt-0.6.4.ebuild:
diff --git a/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.7.0.ebuild b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.7.0.ebuild
new file mode 100644
index 000000000000..fbaa8c1c33a1
--- /dev/null
+++ b/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu-qt/libdbusmenu-qt-0.7.0.ebuild,v 1.1 2011/02/06 19:12:39 tampakrap Exp $
+
+EAPI=3
+
+QT_DEPEND="4.6.3"
+inherit cmake-utils virtualx
+
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git
+
+ EGIT_REPO_URI="git://gitorious.org/dbusmenu/dbusmenu-qt.git"
+
+ KEYWORDS=""
+else
+ # We are using snapshots from Aurelien's repos, as advised in kde-packager ml
+ # This is because version 0.6.3 removed code from the official version,
+ # because Canonical has no copyright on it
+ #SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A library providing Qt implementation of DBusMenu specification"
+HOMEPAGE="https://launchpad.net/libdbusmenu-qt/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug"
+
+RDEPEND="
+ >=x11-libs/qt-core-${QT_DEPEND}:4
+ >=x11-libs/qt-gui-${QT_DEPEND}:4[dbus]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/qjson
+ >=x11-libs/qt-test-${QT_DEPEND}:4
+ )
+"
+
+DOCS=(NEWS README)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}/tests" > /dev/null
+ local ctestargs
+ [[ -n ${TEST_VERBOSE} ]] && ctestargs="--extra-verbose --output-on-failure"
+
+ export maketype="ctest ${ctestargs}"
+ virtualmake || die "Tests failed."
+
+ popd > /dev/null
+}