summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-12-30 14:11:43 +0000
committerJory Pratt <anarchy@gentoo.org>2010-12-30 14:11:43 +0000
commit53224b91ce081c9ef34c087da1735f09d041f5bd (patch)
tree83e1fb8ce0bb4e57dc1754b4f77c2119e36450dd /dev-libs/jemalloc
parentAdd fix for Memory Corruption Vulnerability (CVE-2010-2575, bug 334469), stra... (diff)
downloadgentoo-2-53224b91ce081c9ef34c087da1735f09d041f5bd.tar.gz
gentoo-2-53224b91ce081c9ef34c087da1735f09d041f5bd.tar.bz2
gentoo-2-53224b91ce081c9ef34c087da1735f09d041f5bd.zip
add jemalloc to tree
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog10
-rw-r--r--dev-libs/jemalloc/files/jemalloc-strip-optimization.patch25
-rw-r--r--dev-libs/jemalloc/jemalloc-2.0.1.ebuild38
-rw-r--r--dev-libs/jemalloc/metadata.xml13
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
new file mode 100644
index 000000000000..a45caa9aceef
--- /dev/null
+++ b/dev-libs/jemalloc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/jemalloc
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.1 2010/12/30 14:11:43 anarchy Exp $
+
+*jemalloc-2.0.1 (30 Dec 2010)
+
+ 30 Dec 2010; Jory A. Pratt <anarchy@gentoo.org> +jemalloc-2.0.1.ebuild,
+ +files/jemalloc-strip-optimization.patch, +metadata.xml:
+ initial import to tree
+
diff --git a/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch b/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch
new file mode 100644
index 000000000000..60b7d6c22ff1
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac 2010-02-22 12:07:05.000000000 +0100
++++ b/configure.ac 2010-02-22 12:08:29.000000000 +0100
+@@ -296,21 +296,6 @@
+ fi
+ AC_SUBST([enable_debug])
+
+-dnl Only optimize if not debugging.
+-if test "x$enable_debug" = "x0" -a "x$no_CFLAGS" = "xyes" ; then
+- dnl Make sure that an optimization flag was not specified in EXTRA_CFLAGS.
+- optimize="no"
+- echo "$EXTRA_CFLAGS" | grep "\-O" >/dev/null || optimize="yes"
+- if test "x${optimize}" = "xyes" ; then
+- if test "x$GCC" = "xyes" ; then
+- JE_CFLAGS_APPEND([-O3])
+- JE_CFLAGS_APPEND([-funroll-loops])
+- else
+- JE_CFLAGS_APPEND([-O])
+- fi
+- fi
+-fi
+-
+ dnl Do not enable statistics calculation by default.
+ AC_ARG_ENABLE([stats],
+ [AS_HELP_STRING([--enable-stats], [Enable statistics calculation/reporting])],
+
diff --git a/dev-libs/jemalloc/jemalloc-2.0.1.ebuild b/dev-libs/jemalloc/jemalloc-2.0.1.ebuild
new file mode 100644
index 000000000000..47da41635aeb
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.0.1.ebuild,v 1.1 2010/12/30 14:11:43 anarchy Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug profile stats"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-strip-optimization.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable profile prof) \
+ $(use_enable stats) \
+ || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
diff --git a/dev-libs/jemalloc/metadata.xml b/dev-libs/jemalloc/metadata.xml
new file mode 100644
index 000000000000..543b1a220574
--- /dev/null
+++ b/dev-libs/jemalloc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mozilla</herd>
+ <longdescription lang="en">
+ Jemalloc is a general-purpose scalable concurrent allocator
+ </longdescription>
+ <use>
+ <flag name='profile'>Enable allocation profiling</flag>
+ <flag name='stats'>Enable statistics calculation/reporting</flag>
+ </use>
+</pkgmetadata>
+