summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-30 17:42:34 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-30 17:42:34 +0000
commit51fbf652ad3b9aee21604464992f3d3389a54e3a (patch)
tree53acb6f21f0d3a1d5816549867a4259d44a6df13 /dev-libs/intel-common
parentRemove old. (diff)
downloadgentoo-2-51fbf652ad3b9aee21604464992f3d3389a54e3a.tar.gz
gentoo-2-51fbf652ad3b9aee21604464992f3d3389a54e3a.tar.bz2
gentoo-2-51fbf652ad3b9aee21604464992f3d3389a54e3a.zip
dev-libs/intel-common: Version Bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-libs/intel-common')
-rw-r--r--dev-libs/intel-common/ChangeLog7
-rw-r--r--dev-libs/intel-common/intel-common-15.0.1.133.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/intel-common/ChangeLog b/dev-libs/intel-common/ChangeLog
index 9b19cbff5834..05e8620c9ca6 100644
--- a/dev-libs/intel-common/ChangeLog
+++ b/dev-libs/intel-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/intel-common
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.17 2014/09/15 12:34:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/ChangeLog,v 1.18 2014/11/30 17:42:34 jlec Exp $
+
+*intel-common-15.0.1.133 (30 Nov 2014)
+
+ 30 Nov 2014; Justin Lecher <jlec@gentoo.org> +intel-common-15.0.1.133.ebuild:
+ Version Bump
*intel-common-15.0.0.090-r1 (15 Sep 2014)
diff --git a/dev-libs/intel-common/intel-common-15.0.1.133.ebuild b/dev-libs/intel-common/intel-common-15.0.1.133.ebuild
new file mode 100644
index 000000000000..0fa159cb9b5d
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-15.0.1.133.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/intel-common/intel-common-15.0.1.133.ebuild,v 1.1 2014/11/30 17:42:34 jlec Exp $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=4992
+INTEL_DPV=2015_update1
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+CHECKREQS_DISK_BUILD=375M
+
+pkg_setup() {
+ einfo ${INTEL_SDP_EDIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common compilerpro-common-pset"
+ if use compiler; then
+ INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common ccompxe compxe fcompxe"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}