summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2005-06-22 20:37:22 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2005-06-22 20:37:22 +0000
commit770b6ce927219899595319741426a3135f832006 (patch)
tree4561de34fd062e3c6fd84022da255f77993c5ab7 /dev-libs/ffcall/ffcall-1.10.ebuild
parenttrailing whitespace (diff)
downloadgentoo-2-770b6ce927219899595319741426a3135f832006.tar.gz
gentoo-2-770b6ce927219899595319741426a3135f832006.tar.bz2
gentoo-2-770b6ce927219899595319741426a3135f832006.zip
Added version 1.10 of ffcall; added metadata.xml; added myself for maintership (optional dependency of core GNUstep libs)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/ffcall/ffcall-1.10.ebuild')
-rw-r--r--dev-libs/ffcall/ffcall-1.10.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/ffcall/ffcall-1.10.ebuild b/dev-libs/ffcall/ffcall-1.10.ebuild
new file mode 100644
index 000000000000..0dfc059b7a80
--- /dev/null
+++ b/dev-libs/ffcall/ffcall-1.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.10.ebuild,v 1.1 2005/06/22 20:37:22 fafhrd Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="foreign function call libraries"
+HOMEPAGE="http://www.haible.de/bruno/packages-ffcall.html"
+SRC_URI="http://www.haible.de/bruno/gnu/${P}.tar.gz"
+
+# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
+# or in derivate works of GNUstep, the included parts of ffcall are
+# under GNU LGPL." -ffcall author
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~hppa ~alpha ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [ "${ARCH}" == "alpha" ] && cpu_setting='CPU=alpha'
+
+ append-flags -fPIC
+
+ econf || die "./configure failed"
+ make ${cpu_setting} || die
+}
+
+src_install() {
+ dodoc ChangeLog NEWS README
+ dohtml avcall/avcall.html \
+ callback/callback.html \
+ callback/trampoline_r/trampoline_r.html \
+ trampoline/trampoline.html \
+ vacall/vacall.html
+ doman avcall/avcall.3 \
+ callback/callback.3 \
+ callback/trampoline_r/trampoline_r.3 \
+ trampoline/trampoline.3 \
+ vacall/vacall.3
+ dolib.a avcall/.libs/libavcall.a \
+ avcall/.libs/libavcall.la \
+ vacall/libvacall.a \
+ callback/.libs/libcallback.a \
+ callback/.libs/libcallback.la \
+ trampoline/libtrampoline.a
+ insinto /usr/include
+ doins avcall/avcall.h \
+ callback/callback.h \
+ trampoline/trampoline.h \
+ callback/trampoline_r/trampoline_r.h \
+ vacall/vacall.h \
+ callback/vacall_r.h
+}