summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-03-06 16:08:07 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-03-06 16:08:07 +0000
commita810e3303a6fec3fa125b254c008737a2ef748cf (patch)
tree7b166563a74924ddef4d82eee69a08388615d590 /dev-libs/elfio/files
parentstable x86; security bug 153911 (diff)
downloadgentoo-2-a810e3303a6fec3fa125b254c008737a2ef748cf.tar.gz
gentoo-2-a810e3303a6fec3fa125b254c008737a2ef748cf.tar.bz2
gentoo-2-a810e3303a6fec3fa125b254c008737a2ef748cf.zip
New ebuild, thanks to MATSUU Takuto wrt bug #127026
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-libs/elfio/files')
-rw-r--r--dev-libs/elfio/files/digest-elfio-1.0.33
-rw-r--r--dev-libs/elfio/files/elfio-1.0.3-shared.patch83
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/elfio/files/digest-elfio-1.0.3 b/dev-libs/elfio/files/digest-elfio-1.0.3
new file mode 100644
index 000000000000..1f72a8915e07
--- /dev/null
+++ b/dev-libs/elfio/files/digest-elfio-1.0.3
@@ -0,0 +1,3 @@
+MD5 fd6fca12c7b43f6c01d30b23d22aaefe ELFIO-1.0.3.tar.gz 308560
+RMD160 f89212b30df5ede1339aca0f66f4e40b36d083ca ELFIO-1.0.3.tar.gz 308560
+SHA256 e8cdd3895c4f6e5ed2422a2151e7940f9085a1c10d1f0508ed03b1c4860bcada ELFIO-1.0.3.tar.gz 308560
diff --git a/dev-libs/elfio/files/elfio-1.0.3-shared.patch b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
new file mode 100644
index 000000000000..01e67dfe98bc
--- /dev/null
+++ b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
@@ -0,0 +1,83 @@
+diff -ur ELFIO-1.0.3.orig/configure.in ELFIO-1.0.3/configure.in
+--- ELFIO-1.0.3.orig/configure.in 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/configure.in 2007-03-06 16:37:08.000000000 +0100
+@@ -7,6 +7,7 @@
+ AC_PROG_CXX
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+
+diff -ur ELFIO-1.0.3.orig/ELFIO/Makefile.am ELFIO-1.0.3/ELFIO/Makefile.am
+--- ELFIO-1.0.3.orig/ELFIO/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/ELFIO/Makefile.am 2007-03-06 16:36:45.000000000 +0100
+@@ -1,6 +1,6 @@
+-lib_LIBRARIES = libELFIO.a
++lib_LTLIBRARIES = libELFIO.la
+
+-libELFIO_a_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
++libELFIO_la_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
+ ELFIOUtils.cpp ELFIRelocation.cpp ELFISection.cpp \
+ ELFISegment.cpp ELFIStrings.cpp ELFISymbols.cpp \
+ ELFODynamic.cpp ELFOImpl.cpp ELFONote.cpp \
+@@ -10,4 +10,4 @@
+ include_HEADERS = ELFI.h ELFIO.h ELFO.h ELFTypes.h
+ noinst_HEADERS = ELFIImpl.h ELFOImpl.h ELFIOUtils.h
+
+-EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+\ No newline at end of file
++EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am ELFIO-1.0.3/Examples/ELFDump/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/ELFDump/Makefile.am 2007-03-06 16:37:51.000000000 +0100
+@@ -3,6 +3,6 @@
+ bin_PROGRAMS = ELFDump
+
+ ELFDump_SOURCES = ELFDump.cpp
+-ELFDump_LDADD = ../../ELFIO/libELFIO.a
++ELFDump_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = ELFDump.dsp ELFDump.dsw ELFDump.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am ELFIO-1.0.3/Examples/RelocationTable/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/RelocationTable/Makefile.am 2007-03-06 16:38:53.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = RelocationTable
+
+ RelocationTable_SOURCES = RelocationTable.cpp
+-RelocationTable_LDADD = ../../ELFIO/libELFIO.a
++RelocationTable_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = RelocationTable.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am ELFIO-1.0.3/Examples/WriteObj/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj/Makefile.am 2007-03-06 16:39:28.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = WriteObj
+
+ WriteObj_SOURCES = WriteObj.cpp
+-WriteObj_LDADD = ../../ELFIO/libELFIO.a
++WriteObj_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = WriteObj.dsp WriteObj.dsw WriteObj.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am ELFIO-1.0.3/Examples/WriteObj2/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj2/Makefile.am 2007-03-06 16:39:40.000000000 +0100
+@@ -3,4 +3,4 @@
+ noinst_PROGRAMS = WriteObj2
+
+ WriteObj2_SOURCES = WriteObj2.cpp
+-WriteObj2_LDADD = ../../ELFIO/libELFIO.a
++WriteObj2_LDADD = ../../ELFIO/libELFIO.la
+diff -ur ELFIO-1.0.3.orig/Examples/Writer/Makefile.am ELFIO-1.0.3/Examples/Writer/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/Writer/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/Writer/Makefile.am 2007-03-06 16:39:10.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = Writer
+
+ Writer_SOURCES = Write.cpp
+-Writer_LDADD = ../../ELFIO/libELFIO.a
++Writer_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = Writer.dsp Writer.dsw Writer.mcp